summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2019-11-18 23:39:56 +0100
committerSebastian Pipping <sping@gentoo.org>2019-11-18 23:47:49 +0100
commite3fa3feb267ade0455c5f36e6faaf0bec54b2a4c (patch)
tree2f9a9bd1f790da9ed4ee62136cbbf12e818a074e /app-emulation/docker-compose/files
parentx11-wm/herbstluftwm: drop myself as a maintainer (diff)
downloadgentoo-e3fa3feb267ade0455c5f36e6faaf0bec54b2a4c.tar.gz
gentoo-e3fa3feb267ade0455c5f36e6faaf0bec54b2a4c.tar.bz2
gentoo-e3fa3feb267ade0455c5f36e6faaf0bec54b2a4c.zip
app-emulation/docker-compose: 1.25.0
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.78, Repoman-2.3.16
Diffstat (limited to 'app-emulation/docker-compose/files')
-rw-r--r--app-emulation/docker-compose/files/docker-compose-1.25.0-setup-py.patch70
1 files changed, 70 insertions, 0 deletions
diff --git a/app-emulation/docker-compose/files/docker-compose-1.25.0-setup-py.patch b/app-emulation/docker-compose/files/docker-compose-1.25.0-setup-py.patch
new file mode 100644
index 000000000000..029dc54bb8f7
--- /dev/null
+++ b/app-emulation/docker-compose/files/docker-compose-1.25.0-setup-py.patch
@@ -0,0 +1,70 @@
+From 8f2924d4146ddb1131e98efbee13a68b5445b7f8 Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Mon, 18 Nov 2019 23:34:51 +0100
+Subject: [PATCH] setup.py: Drop generic upper version boundaries
+
+---
+ setup.py | 36 ++++++++++++++++++------------------
+ 1 file changed, 18 insertions(+), 18 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 23ae08a..97a8fbe 100644
+--- a/setup.py
++++ b/setup.py
+@@ -30,35 +30,35 @@ def find_version(*file_paths):
+
+
+ install_requires = [
+- 'cached-property >= 1.2.0, < 2',
+- 'docopt >= 0.6.1, < 1',
+- 'PyYAML >= 3.10, < 5',
+- 'requests >= 2.20.0, < 3',
+- 'texttable >= 0.9.0, < 2',
+- 'websocket-client >= 0.32.0, < 1',
+- 'docker[ssh] >= 3.7.0, < 5',
+- 'dockerpty >= 0.4.1, < 1',
+- 'six >= 1.3.0, < 2',
+- 'jsonschema >= 2.5.1, < 4',
++ 'cached-property >= 1.2.0',
++ 'docopt >= 0.6.1',
++ 'PyYAML >= 3.10',
++ 'requests >= 2.20.0',
++ 'texttable >= 0.9.0',
++ 'websocket-client >= 0.32.0',
++ 'docker[ssh] >= 3.7.0',
++ 'dockerpty >= 0.4.1',
++ 'six >= 1.3.0',
++ 'jsonschema >= 2.5.1',
+ ]
+
+
+ tests_require = [
+- 'pytest < 6',
++ 'pytest',
+ ]
+
+
+ if sys.version_info[:2] < (3, 4):
+- tests_require.append('mock >= 1.0.1, < 4')
++ tests_require.append('mock >= 1.0.1')
+
+ extras_require = {
+- ':python_version < "3.2"': ['subprocess32 >= 3.5.4, < 4'],
+- ':python_version < "3.4"': ['enum34 >= 1.0.4, < 2'],
+- ':python_version < "3.5"': ['backports.ssl_match_hostname >= 3.5, < 4'],
++ ':python_version < "3.2"': ['subprocess32 >= 3.5.4'],
++ ':python_version < "3.4"': ['enum34 >= 1.0.4'],
++ ':python_version < "3.5"': ['backports.ssl_match_hostname >= 3.5'],
+ ':python_version < "3.3"': ['backports.shutil_get_terminal_size == 1.0.0',
+- 'ipaddress >= 1.0.16, < 2'],
+- ':sys_platform == "win32"': ['colorama >= 0.4, < 1'],
+- 'socks': ['PySocks >= 1.5.6, != 1.5.7, < 2'],
++ 'ipaddress >= 1.0.16'],
++ ':sys_platform == "win32"': ['colorama >= 0.4'],
++ 'socks': ['PySocks >= 1.5.6, != 1.5.7'],
+ }
+
+
+--
+2.23.0
+