summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-09-03 17:14:20 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-09-03 20:44:30 +0200
commit8fcd4203723d39867ea0529416b3fe709a6c4c10 (patch)
tree57a1c0461bbc2f6023822a90f984c7f97fabfbd9 /app-emacs
parentapp-emacs/org-mode: bump to 9.7.11 (diff)
downloadgentoo-8fcd4203723d39867ea0529416b3fe709a6c4c10.tar.gz
gentoo-8fcd4203723d39867ea0529416b3fe709a6c4c10.tar.bz2
gentoo-8fcd4203723d39867ea0529416b3fe709a6c4c10.zip
app-emacs/transient: bump to 0.7.5
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/transient/Manifest1
-rw-r--r--app-emacs/transient/transient-0.7.5.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-emacs/transient/Manifest b/app-emacs/transient/Manifest
index 46be633b0373..ce11ea43472a 100644
--- a/app-emacs/transient/Manifest
+++ b/app-emacs/transient/Manifest
@@ -1,3 +1,4 @@
DIST transient-0.7.2.tar.gz 138256 BLAKE2B c3b425a9b6089b54eb7377d47c7763fda87d9800246de866330dd2ca6ac8561fad5d7429b0b1f0c5f10072e836825d025b08676bd973a793d93e9b32616bcf07 SHA512 2863701146ecf4ac5f4a8025f47737667bc3ee0ca1de70e747a3299c9bb7831c0d9a3853553d79790c929ca9e5fe9f534e2c7499bc37a22ca2fb8d1d28b269fd
DIST transient-0.7.3.tar.gz 139105 BLAKE2B 7ab629632e90b009cb1a306e99c86b997ddf49573188f6923109abfd1be8b32ea857644d807f33b240139150f57e267c8ed674cb15d2888cb82694b653466227 SHA512 d219b821a2cae2529044c390436a28a1213e0d649113ac1f761888298f76ef518e820ff933aa4471ec830f0690c6d0c75e5344aee8c5693677f36d3a3458df2b
DIST transient-0.7.4.tar.gz 139828 BLAKE2B 6ac959237be5f46d4ba381b8c8855ac0b6387405101024e1807af83c98ed7419cbd463fb7c8874b2196d0f5879610903940df34260a70487f3505495d5e47343 SHA512 711bed7c75417778894035fb8fd1006ac78e73c4e545785b94b4f0f8aa1f1903a1426ff5175310e1ab665e29ad4756ffd4ec4b897c1720e33531ec2ce3faf82a
+DIST transient-0.7.5.tar.gz 141189 BLAKE2B 55535f6121467a1f380ec8d6a4afbb810556f914dc30a7c2fb913f2238bd47809f3d8aadfe35cfdae087525048e83beb14380cd3fdf6cae59643191147df4789 SHA512 18d051235b15e95312fcd60ddfa0f0ba85351d6102117717c81f621528a46a6d0f03d918002a7af2702135ebcf53c498f079a12d99ffc68711e20b196045e032
diff --git a/app-emacs/transient/transient-0.7.5.ebuild b/app-emacs/transient/transient-0.7.5.ebuild
new file mode 100644
index 000000000000..f99ae40b0465
--- /dev/null
+++ b/app-emacs/transient/transient-0.7.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Transient commands abstraction for GNU Emacs"
+HOMEPAGE="https://magit.vc/manual/transient/
+ https://github.com/magit/transient/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/magit/${PN}.git"
+else
+ SRC_URI="https://github.com/magit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( CHANGELOG README.org "docs/${PN}.org" )
+ELISP_TEXINFO="docs/${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND="
+ >=app-emacs/compat-30.0.0.0
+"
+BDEPEND="
+ ${RDEPEND}
+ sys-apps/texinfo
+"
+
+src_prepare() {
+ mv lisp/*.el . || die
+
+ elisp_src_prepare
+}