summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-04-07 17:55:54 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-04-07 18:20:05 +0200
commit58aba80df8f988340ef655595e687581391831ac (patch)
tree1d850cf2aad7c5cadf20ce54bf7002857d65f059 /app-emacs
parentapp-emacs/lsp-docker: new package; add 1.0.0_p20240327 (diff)
downloadgentoo-58aba80df8f988340ef655595e687581391831ac.tar.gz
gentoo-58aba80df8f988340ef655595e687581391831ac.tar.bz2
gentoo-58aba80df8f988340ef655595e687581391831ac.zip
app-emacs/dap-mode: bump to 0.7_p20240406
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/dap-mode/Manifest1
-rw-r--r--app-emacs/dap-mode/dap-mode-0.7_p20240406.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/app-emacs/dap-mode/Manifest b/app-emacs/dap-mode/Manifest
index 2ddf4ae9ac55..460951582e39 100644
--- a/app-emacs/dap-mode/Manifest
+++ b/app-emacs/dap-mode/Manifest
@@ -1 +1,2 @@
DIST dap-mode-0.7.tar.gz 6147924 BLAKE2B 300a058134e58e5ae5f94fd62251c1c621478b3148e7453ef5acd062a2c6088f0036e3ac2588ce22138d39b77221396c3f310177914b08a2bbc177cfbc14efce SHA512 ba8d8e2b3e9b699b27226b13624b24a6f78ea884fe9e8e7667537e06285354bf996f7f5d621e2576ad34bbf02ede316bf001444b8b5c67fa604aa5dc5d9416ff
+DIST dap-mode-0.7_p20240406.tar.gz 6376637 BLAKE2B e4e2c2e4684b9b0d24f86ab072596a0e9d42eaa685cb4f07d8e766dd7a627e31b1d23248d8bb7872565ce4248c95d242c72e9eace47bbbdcd0634f1fc441fc01 SHA512 6266e5f61a2052c811a594c354d69b19fa5d69f0279950493971244b3a94f6193dfb71435cfa4973b0bbf5a5ae99a70459223ccacc98721eb215de271bdb45f8
diff --git a/app-emacs/dap-mode/dap-mode-0.7_p20240406.ebuild b/app-emacs/dap-mode/dap-mode-0.7_p20240406.ebuild
new file mode 100644
index 000000000000..c5a432b4df43
--- /dev/null
+++ b/app-emacs/dap-mode/dap-mode-0.7_p20240406.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Debug Adapter Protocol mode"
+HOMEPAGE="https://github.com/emacs-lsp/dap-mode/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/emacs-lsp/${PN}"
+else
+ COMMIT_SHA=a414b18ea774ae75bdc7344af500b6f15849a65d
+ SRC_URI="https://github.com/emacs-lsp/${PN}/archive/${COMMIT_SHA}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT_SHA}"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-emacs/bui
+ app-emacs/dash
+ app-emacs/f
+ app-emacs/ht
+ app-emacs/hydra
+ app-emacs/lsp-docker
+ app-emacs/lsp-mode
+ app-emacs/lsp-treemacs
+ app-emacs/posframe
+ app-emacs/s
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-dap-ui-images-root-dir.patch"
+)
+
+DOCS=( CHANGELOG.org README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests ert-runner test
+
+src_prepare() {
+ elisp_src_prepare
+
+ sed "s|@SITEETC@|${SITEETC}/${PN}|" -i dap-ui.el || die
+}
+
+src_install() {
+ elisp_src_install
+
+ insinto "${SITEETC}/${PN}"
+ doins -r icons
+}