summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Turner <jturner.usa+gentoo@gmail.com>2021-09-17 00:31:36 -0400
committerSam James <sam@gentoo.org>2021-09-18 03:53:19 +0100
commit4a3d495522c3822047f1187d8b0a15e4b3183a54 (patch)
tree7ab3b488298a2c0654ed278e2467daaddbf58a88 /app-emacs
parentapp-emacs/pkg-info: created ebuild (diff)
downloadgentoo-4a3d495522c3822047f1187d8b0a15e4b3183a54.tar.gz
gentoo-4a3d495522c3822047f1187d8b0a15e4b3183a54.tar.bz2
gentoo-4a3d495522c3822047f1187d8b0a15e4b3183a54.zip
app-emacs/flycheck: created ebuild
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: John Turner <jturner.usa+gentoo@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/22315 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/flycheck/Manifest1
-rw-r--r--app-emacs/flycheck/files/50flycheck-gentoo.el4
-rw-r--r--app-emacs/flycheck/flycheck-32_p20210825.ebuild26
-rw-r--r--app-emacs/flycheck/metadata.xml20
4 files changed, 51 insertions, 0 deletions
diff --git a/app-emacs/flycheck/Manifest b/app-emacs/flycheck/Manifest
new file mode 100644
index 000000000000..5195b9be5be0
--- /dev/null
+++ b/app-emacs/flycheck/Manifest
@@ -0,0 +1 @@
+DIST flycheck-32_p20210825.tar.gz 1042020 BLAKE2B 1663340de24980b3a1e58929e327841b743495dbd5d5c8306f007d0dfa989707015ceadaf6e5cac673eddb45adf9ec05dc35d8cb35af322c9cde6644194dd75d SHA512 472e25956d804e7f7ba8ebda2e3a7527eaaf3aee47fa5bd43a46ae651f94d857657cf4594f5a1ed0c169ec0ac610139956d182818ffeedf2c4132a5583ca870d
diff --git a/app-emacs/flycheck/files/50flycheck-gentoo.el b/app-emacs/flycheck/files/50flycheck-gentoo.el
new file mode 100644
index 000000000000..5f6c703df909
--- /dev/null
+++ b/app-emacs/flycheck/files/50flycheck-gentoo.el
@@ -0,0 +1,4 @@
+;;; Flycheck site-lisp configuration
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'flycheck-mode "flycheck" nil t)
+(autoload 'global-flycheck-mode "flycheck" nil t)
diff --git a/app-emacs/flycheck/flycheck-32_p20210825.ebuild b/app-emacs/flycheck/flycheck-32_p20210825.ebuild
new file mode 100644
index 000000000000..2f6ead369883
--- /dev/null
+++ b/app-emacs/flycheck/flycheck-32_p20210825.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+NEED_EMACS="24.3"
+
+inherit elisp
+
+DESCRIPTION="Modern on-the-fly syntax checking extension for GNU Emacs"
+HOMEPAGE="https://www.flycheck.org/"
+COMMIT="784f184cdd9f9cb4e3dbb997c09d93e954142842"
+SRC_URI="https://github.com/flycheck/flycheck/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test" # test requires cask and ert-runner which are not packaged yet
+
+RDEPEND=">=app-emacs/dash-2.12.1
+>=app-emacs/pkg-info-0.4"
+
+SITEFILE="50${PN}-gentoo.el"
+DOCS=( README.md )
+ELISP_REMOVE="flycheck-buttercup.el flycheck-ert.el"
diff --git a/app-emacs/flycheck/metadata.xml b/app-emacs/flycheck/metadata.xml
new file mode 100644
index 000000000000..e96ebcfc18fc
--- /dev/null
+++ b/app-emacs/flycheck/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>jturner.usa+gentoo@gmail.com</email>
+ <name>John Turner</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">flycheck/flycheck</remote-id>
+ <doc>https://github.com/flycheck/flycheck/blob/master/README.md</doc>
+ </upstream>
+ <longdescription>
+ Flycheck is a modern on-the-fly syntax checking extension for GNU Emacs,
+ intended as replacement for the older Flymake extension which is part of GNU Emacs.
+ </longdescription>
+</pkgmetadata>