summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-10-15 12:59:28 +0200
committerUlrich Müller <ulm@gentoo.org>2019-10-15 13:02:02 +0200
commit2721f3949405b09dadb5d63f4fbe378bc797bc32 (patch)
tree6e49de9f35b51a2fc444ca819cc7c3fbed8af4ae /app-emacs/sokoban
parentwww-client/vivaldi: Version 2.8.1664.44_p1 (diff)
downloadgentoo-2721f3949405b09dadb5d63f4fbe378bc797bc32.tar.gz
gentoo-2721f3949405b09dadb5d63f4fbe378bc797bc32.tar.bz2
gentoo-2721f3949405b09dadb5d63f4fbe378bc797bc32.zip
app-emacs/sokoban: Version bump.
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/sokoban')
-rw-r--r--app-emacs/sokoban/Manifest1
-rw-r--r--app-emacs/sokoban/sokoban-1.4.8.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/app-emacs/sokoban/Manifest b/app-emacs/sokoban/Manifest
index cf3b6783d46e..6f288ec25c9b 100644
--- a/app-emacs/sokoban/Manifest
+++ b/app-emacs/sokoban/Manifest
@@ -1 +1,2 @@
+DIST sokoban-1.4.8.tar 71680 BLAKE2B faf7218dc4d1a629008b1d7fa79a9f747eeda056a89cf9e677f0b20a3dae1dad468a4f968da89be6a1daee0188ea36eb64e02c8a54f6948a89f5dcd039038c39 SHA512 bca8ba4c6357768bd3ec84d8093697acb0fcc84a565290f9517e844bc39301e9ebe7a0e8d3a2c9ef2304387ff539366048a2d2334990f1b7e3895ea1b113e613
DIST sokoban-1.4.tar 61440 BLAKE2B b0348084517e4fddfe5adffc6fac3020bc7147983733354fe18bbe90bdd49e620dfb392385c0dbb7ffed47bfd05d6b9b28cdf1bd81cc182fde83b243d33b6415 SHA512 8c04f509013e1d8f6e8cc1e182ec253fc84870e5733623038ea03f2447952dcbc77236c64b158ea4e4613dafce192f2c4b50aac3e1e219a049a6a951a44a7ac1
diff --git a/app-emacs/sokoban/sokoban-1.4.8.ebuild b/app-emacs/sokoban/sokoban-1.4.8.ebuild
new file mode 100644
index 000000000000..b1a92acefeaf
--- /dev/null
+++ b/app-emacs/sokoban/sokoban-1.4.8.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp
+
+DESCRIPTION="Implementation of Sokoban for Emacs"
+HOMEPAGE="https://elpa.gnu.org/packages/sokoban.html"
+SRC_URI="https://elpa.gnu.org/packages/${P}.tar"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+ELISP_REMOVE="sokoban-pkg.el"
+SITEFILE="50${PN}-gentoo.el"
+DOCS="ChangeLog"
+
+src_install() {
+ elisp_src_install
+ insinto "${SITEETC}/${PN}"
+ doins sokoban.levels
+}