summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-04-29 01:45:54 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-04-29 01:53:35 +0200
commit05de8a8991449ee5f346cae9c9003e030a9e71cc (patch)
tree335030b3406f1b47e7f204c63b84be4bbfdd6a32 /app-emacs/slime
parentapp-emacs/slime: drop old 2.29 (diff)
downloadgentoo-05de8a8991449ee5f346cae9c9003e030a9e71cc.tar.gz
gentoo-05de8a8991449ee5f346cae9c9003e030a9e71cc.tar.bz2
gentoo-05de8a8991449ee5f346cae9c9003e030a9e71cc.zip
app-emacs/slime: bump to 2.30
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/slime')
-rw-r--r--app-emacs/slime/Manifest1
-rw-r--r--app-emacs/slime/slime-2.30.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/app-emacs/slime/Manifest b/app-emacs/slime/Manifest
index 04c37e49512d..4f26a5bb8c20 100644
--- a/app-emacs/slime/Manifest
+++ b/app-emacs/slime/Manifest
@@ -1 +1,2 @@
DIST slime-2.29.1.tar.gz 828475 BLAKE2B 90ad92b34e8bc90fb549f4dec00dde18a50edee95f4cb77db2ccdb024c70cc03ae6b8942c8a2200b14e9db1cf3e2a6cda52f847443552efac33c30130a04534e SHA512 5e93a13814584c4c02b2fe4f5703212312ef9f6c810030045602dc8b38b1374193cd2f9739f791808b29e27b33e295c79c6d34b9ed864798961f12ce075cef74
+DIST slime-2.30.tar.gz 774034 BLAKE2B ad64caabfbb76418ad197a3114b9cf69befe4f626febaa97d568313af860c6bacef9322f27742451ccf009956cb68d0608c7c716be5f922c99fb1f245be29309 SHA512 88378df3e2ec065b052be06cb5638a42d07bc05a6e3cd3fc6907f629988a5d0fd90be050a85d73c38bf407dea6049a89fe1525e3308eef79f12f82d235b62e22
diff --git a/app-emacs/slime/slime-2.30.ebuild b/app-emacs/slime/slime-2.30.ebuild
new file mode 100644
index 000000000000..faeafd09686d
--- /dev/null
+++ b/app-emacs/slime/slime-2.30.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="SLIME, the Superior Lisp Interaction Mode (Extended)"
+HOMEPAGE="https://slime.common-lisp.dev/
+ https://github.com/slime/slime/"
+SRC_URI="https://github.com/slime/slime/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain GPL-2+ GPL-3+ LLGPL-2.1 ZLIB xref? ( xref.lisp )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="doc xref"
+RESTRICT="test" # tests fail to contact sbcl
+
+RDEPEND="
+ virtual/commonlisp
+ dev-lisp/asdf
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ >=sys-apps/texinfo-5.1
+ doc? (
+ virtual/texi2dvi
+ )
+"
+
+SITEFILE="70${PN}-gentoo.el"
+
+src_prepare() {
+ default
+
+ # Remove xref.lisp (which is non-free) unless USE flag is set
+ use xref || rm xref.lisp || die
+}
+
+src_compile() {
+ elisp-compile *.el
+ BYTECOMPFLAGS="${BYTECOMPFLAGS} -L contrib -l slime" \
+ elisp-compile contrib/*.el lib/*.el
+
+ emake -C doc slime.info
+ if use doc; then
+ VARTEXFONTS="${T}"/fonts emake -C doc all
+ fi
+}
+
+src_install() {
+ # Install core
+ elisp-install ${PN} *.{el,elc,lisp}
+
+ # Install contribs
+ elisp-install ${PN}/contrib/ contrib/*.{el,elc} contrib/swank*
+
+ # Install lib
+ elisp-install ${PN}/lib/ lib/*.{el,elc}
+
+ # Install swank
+ elisp-install ${PN}/swank/ swank/*.lisp
+
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ # Install docs
+ dodoc README.md CONTRIBUTING.md NEWS PROBLEMS
+ newdoc contrib/README.md README-contrib.md
+ doinfo doc/slime.info
+ use doc && dodoc doc/*.pdf
+
+ # Bug #656760
+ touch "${ED}${SITELISP}/${PN}/lib/.nosearch" || die
+}