summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-07-10 16:40:49 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-07-10 20:55:55 +0200
commit959cf4f168404a5b0fa4aa943042fdf6dc444c3f (patch)
tree556da2bbe17a44abce9debdbc2085140f70a3a57 /app-emacs/plz
parentapp-emacs/plz: drop old 0.5.4 (diff)
downloadgentoo-959cf4f168404a5b0fa4aa943042fdf6dc444c3f.tar.gz
gentoo-959cf4f168404a5b0fa4aa943042fdf6dc444c3f.tar.bz2
gentoo-959cf4f168404a5b0fa4aa943042fdf6dc444c3f.zip
app-emacs/plz: bump to 0.7
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/plz')
-rw-r--r--app-emacs/plz/Manifest1
-rw-r--r--app-emacs/plz/plz-0.7.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-emacs/plz/Manifest b/app-emacs/plz/Manifest
index 382b25dd1c65..bb20e4d72e01 100644
--- a/app-emacs/plz/Manifest
+++ b/app-emacs/plz/Manifest
@@ -1 +1,2 @@
DIST plz-0.6.tar.gz 102322 BLAKE2B 61bda1b01262f74a6aac0c452b0f06fc2559a287e41ff64b809c6512cc960802084af792fd26a2ac7e82918724b5b9840609cabc5fadc1e637a4e0048b89f171 SHA512 8e281e750d3536ec7bac1235925d1aca559d0f0e1778721b284e05c6a0a53d4b85342eb39476d4eeaaf40ce0c99578108655ad1761619c07d8b131458595d185
+DIST plz-0.7.tar.gz 105630 BLAKE2B 882e5141d6e069da3c7b32706e459e5bcc71abb1277be39162310cde413784202d21bae4bbf8b61f2b72c0edf71ef7b4615685246be17905bbabc9626a2035d6 SHA512 f3300843d30e4b219e4c3f9e898f99f1f3987c73195fdd40a9022c0ac7e09ac25f217adf619b61fb36e2a4d0ea494f5546226e2d1dd85514d1b111f769b7f5ef
diff --git a/app-emacs/plz/plz-0.7.ebuild b/app-emacs/plz/plz-0.7.ebuild
new file mode 100644
index 000000000000..307393bd9848
--- /dev/null
+++ b/app-emacs/plz/plz-0.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="HTTP library with curl backend for GNU Emacs"
+HOMEPAGE="https://github.com/alphapapa/plz.el/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/alphapapa/plz.el.git"
+else
+ SRC_URI="https://github.com/alphapapa/plz.el/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/plz.el-${PV}
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+PROPERTIES="test_network" # Tests require network access.
+RESTRICT="test"
+
+RDEPEND="net-misc/curl"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests ert tests -l tests/test-plz.el
+
+src_install() {
+ elisp_src_install
+
+ doinfo ${PN}.info
+}