summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-06-19 20:28:49 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-06-19 20:29:35 +0200
commit212f427fa3232493f19cd2d2e397b80efbfad39d (patch)
tree44a64c81954d44c0c59c568cece6299cb17c6681 /app-emacs/plz
parentapp-emacs/elixir-mode: bump to 2.4.1 (diff)
downloadgentoo-212f427fa3232493f19cd2d2e397b80efbfad39d.tar.gz
gentoo-212f427fa3232493f19cd2d2e397b80efbfad39d.tar.bz2
gentoo-212f427fa3232493f19cd2d2e397b80efbfad39d.zip
app-emacs/plz: bump to 0.6
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/plz')
-rw-r--r--app-emacs/plz/Manifest1
-rw-r--r--app-emacs/plz/plz-0.6.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/app-emacs/plz/Manifest b/app-emacs/plz/Manifest
index 11c45c67187d..7f13fbbf31f9 100644
--- a/app-emacs/plz/Manifest
+++ b/app-emacs/plz/Manifest
@@ -1 +1,2 @@
DIST plz-0.5.4.tar.gz 101382 BLAKE2B cba7089ed3f6c6d616d6d8b506e9779c1fdc56b8c048010cb2e61f03d83669aa3475314936c9fc4b02d473484268a303495605e785840644bc3b9b92f50be090 SHA512 3a64a49efcf32191099abcd5dd5955b02ce3afa98ec3ecd79d4bfaadf52bc4a5602fda3aca4482e77e465e5d071400ae8200cf900e4f0ed931e93e1458303fa1
+DIST plz-0.6.tar.gz 102322 BLAKE2B 61bda1b01262f74a6aac0c452b0f06fc2559a287e41ff64b809c6512cc960802084af792fd26a2ac7e82918724b5b9840609cabc5fadc1e637a4e0048b89f171 SHA512 8e281e750d3536ec7bac1235925d1aca559d0f0e1778721b284e05c6a0a53d4b85342eb39476d4eeaaf40ce0c99578108655ad1761619c07d8b131458595d185
diff --git a/app-emacs/plz/plz-0.6.ebuild b/app-emacs/plz/plz-0.6.ebuild
new file mode 100644
index 000000000000..fc3776f2a6fa
--- /dev/null
+++ b/app-emacs/plz/plz-0.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="HTTP library with curl backend for GNU Emacs"
+HOMEPAGE="https://github.com/alphapapa/plz.el/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/alphapapa/plz.el.git"
+else
+ SRC_URI="https://github.com/alphapapa/plz.el/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/plz.el-${PV}
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+# Tests require network access.
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="net-misc/curl"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests ert tests -l tests/test-plz.el
+
+src_install() {
+ elisp_src_install
+
+ doinfo plz.info
+}