summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-09-03 16:51:31 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-09-03 20:44:28 +0200
commitba6c116a753c7af39de52891df6be0440d4fd4fd (patch)
treeb2bed4cd77cc636bb9620b04ffe00127a36e75fd /app-emacs/helm
parentapp-emacs/async: add live 9999 version (diff)
downloadgentoo-ba6c116a753c7af39de52891df6be0440d4fd4fd.tar.gz
gentoo-ba6c116a753c7af39de52891df6be0440d4fd4fd.tar.bz2
gentoo-ba6c116a753c7af39de52891df6be0440d4fd4fd.zip
app-emacs/helm: bump to 4.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/helm')
-rw-r--r--app-emacs/helm/Manifest1
-rw-r--r--app-emacs/helm/helm-4.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/app-emacs/helm/Manifest b/app-emacs/helm/Manifest
index e0b295acefaf..94bcf035dfb8 100644
--- a/app-emacs/helm/Manifest
+++ b/app-emacs/helm/Manifest
@@ -1 +1,2 @@
DIST helm-3.9.9.tar.gz 2384860 BLAKE2B 19ee0114beb2e27c99da5c5df361f01de3a24a106f9c36205e72fd0d7c22bcaecd3399a84f4803b1d0df315977b06ef7a04a0c45860d64f541014aaf229437a5 SHA512 114b25d8c223a11bef327612760e388f49c876e10683f8fed9cc58f380047f932b2782fcb99de1d37cc352fd168c3fc8ba9e358321aca46bbcd130a17e7d37ec
+DIST helm-4.0.tar.gz 2391038 BLAKE2B b3bd0c3736bb20218ed88afda39cebed4853a43915dd9e857d57f459f5531f565435aba19e71a196b808db58d56f54dda1ae9916697f7025055c4b9471df19a1 SHA512 70563293cdd9212ed46bcb13a2dcdb2c669a66314676a34d99102ca517c5e27c6937926c2c063fa1826d7eca4c0c9f61146067d684ca34ac1dacd3d977a0bd77
diff --git a/app-emacs/helm/helm-4.0.ebuild b/app-emacs/helm/helm-4.0.ebuild
new file mode 100644
index 000000000000..9c74ab45f838
--- /dev/null
+++ b/app-emacs/helm/helm-4.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Emacs incremental completion and selection narrowing framework"
+HOMEPAGE="https://emacs-helm.github.io/helm/
+ https://github.com/emacs-helm/helm/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/emacs-helm/${PN}.git"
+else
+ SRC_URI="https://github.com/emacs-helm/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=app-emacs/async-1.9.9
+ app-emacs/async
+ app-emacs/popup
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+PATCHES=( "${FILESDIR}/${PN}-3.8.8-no-autoload-check.patch" )
+
+DOCS=( NEWS.org README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}
+
+src_install() {
+ elisp_src_install
+
+ exeinto /usr/bin/
+ doexe emacs-helm.sh
+}