summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-06-04 13:27:12 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-06-04 17:07:34 +0200
commit43dec28a8c487a63d3fcc6775ed50ecee30365de (patch)
tree2671185e49d61787af011ca2008dc39f481b535d /app-emacs/helm
parentapp-emacs/helm: drop old 3.9.7 (diff)
downloadgentoo-43dec28a8c487a63d3fcc6775ed50ecee30365de.tar.gz
gentoo-43dec28a8c487a63d3fcc6775ed50ecee30365de.tar.bz2
gentoo-43dec28a8c487a63d3fcc6775ed50ecee30365de.zip
app-emacs/helm: bump to 3.9.9
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/helm')
-rw-r--r--app-emacs/helm/Manifest1
-rw-r--r--app-emacs/helm/helm-3.9.9.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-emacs/helm/Manifest b/app-emacs/helm/Manifest
index e15e1b59ea80..cd7f24d66b1d 100644
--- a/app-emacs/helm/Manifest
+++ b/app-emacs/helm/Manifest
@@ -1 +1,2 @@
DIST helm-3.9.8.tar.gz 2383635 BLAKE2B a6f1efd23ecb6b8156e46b936008de41fbc05e78fd5559a182a703cdfbec590a0409042f33e5d86f77ae969954057b4f2da7720e81db308cd3f3f301826cd9dd SHA512 ce574bb4e1534edc3442adb8b2257fe4e072db9736cc4e265f34e0b6aebd08cf4c599058755a4c453ba14dfa48499c423e549d1189f708b7fa2f048a229ada8f
+DIST helm-3.9.9.tar.gz 2384860 BLAKE2B 19ee0114beb2e27c99da5c5df361f01de3a24a106f9c36205e72fd0d7c22bcaecd3399a84f4803b1d0df315977b06ef7a04a0c45860d64f541014aaf229437a5 SHA512 114b25d8c223a11bef327612760e388f49c876e10683f8fed9cc58f380047f932b2782fcb99de1d37cc352fd168c3fc8ba9e358321aca46bbcd130a17e7d37ec
diff --git a/app-emacs/helm/helm-3.9.9.ebuild b/app-emacs/helm/helm-3.9.9.ebuild
new file mode 100644
index 000000000000..29c9049d8925
--- /dev/null
+++ b/app-emacs/helm/helm-3.9.9.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Emacs incremental completion and selection narrowing framework"
+HOMEPAGE="https://emacs-helm.github.io/helm/
+ https://github.com/emacs-helm/helm/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/emacs-helm/${PN}.git"
+else
+ SRC_URI="https://github.com/emacs-helm/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ app-emacs/async
+ app-emacs/popup
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+PATCHES=( "${FILESDIR}/${PN}-3.8.8-no-autoload-check.patch" )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}
+
+src_install() {
+ elisp_src_install
+
+ exeinto /usr/bin/
+ doexe emacs-helm.sh
+}