summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-02-24 22:06:49 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-02-24 22:50:19 +0100
commit750f28e9a8640c113d0ca81ad0eab0f2dc877f91 (patch)
tree02f5b97638482f43fcde9b55f4f15c856e356546 /app-emacs/consult
parentdev-util/bpftool: Fix automagic llvm depencency (diff)
downloadgentoo-750f28e9a8640c113d0ca81ad0eab0f2dc877f91.tar.gz
gentoo-750f28e9a8640c113d0ca81ad0eab0f2dc877f91.tar.bz2
gentoo-750f28e9a8640c113d0ca81ad0eab0f2dc877f91.zip
app-emacs/consult: bump to 1.3
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/consult')
-rw-r--r--app-emacs/consult/Manifest1
-rw-r--r--app-emacs/consult/consult-1.3.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-emacs/consult/Manifest b/app-emacs/consult/Manifest
index 4bdff09cdcf1..3ad43dad88b3 100644
--- a/app-emacs/consult/Manifest
+++ b/app-emacs/consult/Manifest
@@ -1,2 +1,3 @@
DIST consult-1.1.tar.gz 103352 BLAKE2B 8ad8eff3d65013de40f9ee10abaa6ea39acb6b96543d533bc4a272139778445863d26d06a88a759215ee46a95cc68595e8b3eb4e91db911b6b6f104e97a47cce SHA512 687266605f2b8fa9260362aabacd8508acb5239fa72061efbc002d311cf5ebef6fce8795729ab3fc2915de3455e1744dc9980dba422495340349e8c426c44a28
DIST consult-1.2.tar.gz 103598 BLAKE2B 684ac2c9aca7901ee7ad2d2601327ff57c9fe08b20c6314526b1166bec0276bdf129bd80d09a54b15a1cf91030ed7d2377d91ed49d8ba4e177e3438264587302 SHA512 f8c927bbe447b9337faa511bec59188198d2a6ee0acd142bd48603f09634b7219e183c509245fa7026145c3ca688a6ab152fc0ededc0bf81ee3fb019ef1d675f
+DIST consult-1.3.tar.gz 103808 BLAKE2B 180f775ac76a4e0c40b8bbeeb254a8eccc3afd01ed8de792f4847e3cdee85201384816fca54bbf29d8b5a4aa8f091e298710e10d8dc1b495b1517cdd91e4500c SHA512 fab8811d4a95ba947334c9098971f24071f0a86df16e44e92a3acaa1b05e4169d41f0d8c05251ed0053a5299f1e0db3b70ff51cfb9165be7a848872412235aee
diff --git a/app-emacs/consult/consult-1.3.ebuild b/app-emacs/consult/consult-1.3.ebuild
new file mode 100644
index 000000000000..e1f29886c2e1
--- /dev/null
+++ b/app-emacs/consult/consult-1.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27
+
+inherit elisp
+
+DESCRIPTION="Consulting complete-read for GNU Emacs"
+HOMEPAGE="https://github.com/minad/consult/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/minad/${PN}.git"
+else
+ SRC_URI="https://github.com/minad/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND=">=app-emacs/compat-28.1"
+BDEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}