summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2024-02-25 10:53:25 +0100
committerUlrich Müller <ulm@gentoo.org>2024-02-25 10:55:57 +0100
commit4d9e07e0da24b22e15c6493f0fce5ba06323a8ab (patch)
tree7ad6148c8294b9529f70128c089f5ee9e9ed2477 /app-editors
parentdev-tcltk/mysqltcl: drop QA warning (diff)
downloadgentoo-4d9e07e0da24b22e15c6493f0fce5ba06323a8ab.tar.gz
gentoo-4d9e07e0da24b22e15c6493f0fce5ba06323a8ab.tar.bz2
gentoo-4d9e07e0da24b22e15c6493f0fce5ba06323a8ab.zip
app-editors/emacs: Disable tests that hang with gnupg-2.2.42
See etc/PROBLEMS, "Saving a file encrypted with GnuPG via EasyPG hangs". Bug: https://lists.gnu.org/archive/html/emacs-devel/2024-02/msg00546.html Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/emacs/emacs-29.2-r1.ebuild10
1 files changed, 10 insertions, 0 deletions
diff --git a/app-editors/emacs/emacs-29.2-r1.ebuild b/app-editors/emacs/emacs-29.2-r1.ebuild
index e6d111a23c30..6b943b04d393 100644
--- a/app-editors/emacs/emacs-29.2-r1.ebuild
+++ b/app-editors/emacs/emacs-29.2-r1.ebuild
@@ -450,6 +450,16 @@ src_test() {
)
use xpm || exclude_tests+=( %src/image-tests.el )
+ # Some tests hang with gnupg-2.2.42
+ local gpgver=$(best_version app-crypt/gnupg)
+ gpgver=${gpgver#*gnupg-}
+ [[ -n ${gpgver} ]] \
+ && ver_test "${gpgver}" -ge 2.2.42 && ver_test "${gpgver}" -lt 2.3 \
+ && exclude_tests+=(
+ %lisp/epg-tests.el
+ %lisp/gnus/mml-sec-tests.el
+ )
+
# Redirect GnuPG's sockets, in order not to exceed the 108 char limit
# for socket paths on Linux.
mkdir "${T}"/gpg || die