summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOskari Pirhonen <xxc3ncoredxx@gmail.com>2023-02-16 01:10:13 -0600
committerSam James <sam@gentoo.org>2023-02-18 04:32:39 +0000
commit1882a663653da85fc261820369a2a9acb3168a39 (patch)
tree0e6fb9593276343a6d8e57eb043d9d3edbccb3c1 /app-editors
parentapp-editors/vim: remove manual patch application (diff)
downloadgentoo-1882a663653da85fc261820369a2a9acb3168a39.tar.gz
gentoo-1882a663653da85fc261820369a2a9acb3168a39.tar.bz2
gentoo-1882a663653da85fc261820369a2a9acb3168a39.zip
app-editors/vim-core: remove manual patch application
Signed-off-by: Oskari Pirhonen <xxc3ncoredxx@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/29601 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vim-core/vim-core-9.0.1000.ebuild14
-rw-r--r--app-editors/vim-core/vim-core-9.0.1157.ebuild14
-rw-r--r--app-editors/vim-core/vim-core-9999.ebuild14
3 files changed, 24 insertions, 18 deletions
diff --git a/app-editors/vim-core/vim-core-9.0.1000.ebuild b/app-editors/vim-core/vim-core-9.0.1000.ebuild
index ba583b0f4e11..98d156f8fe5e 100644
--- a/app-editors/vim-core/vim-core-9.0.1000.ebuild
+++ b/app-editors/vim-core/vim-core-9.0.1000.ebuild
@@ -31,6 +31,13 @@ IUSE="nls acl minimal"
DEPEND=">=sys-libs/ncurses-5.2-r2:0"
BDEPEND="sys-devel/autoconf"
+if [[ ${PV} != 9999* ]]; then
+ # Gentoo patches to fix runtime issues, cross-compile errors, etc
+ PATCHES=(
+ "${WORKDIR}/vim-patches-vim-${VIM_PATCHES_VERSION}-patches"
+ )
+fi
+
pkg_setup() {
# people with broken alphabets run into trouble. bug #82186.
unset LANG LC_ALL
@@ -38,10 +45,7 @@ pkg_setup() {
}
src_prepare() {
- if [[ ${PV} != 9999* ]] ; then
- # Gentoo patches to fix runtime issues, cross-compile errors, etc
- eapply "${WORKDIR}"/vim-patches-vim-${VIM_PATCHES_VERSION}-patches
- fi
+ default
# Fixup a script to use awk instead of nawk
sed -i \
@@ -106,8 +110,6 @@ src_prepare() {
# Remove src/auto/configure file.
rm -v src/auto/configure || die "rm configure failed"
-
- eapply_user
}
src_configure() {
diff --git a/app-editors/vim-core/vim-core-9.0.1157.ebuild b/app-editors/vim-core/vim-core-9.0.1157.ebuild
index a9836a9b50d9..64e63ae0b84e 100644
--- a/app-editors/vim-core/vim-core-9.0.1157.ebuild
+++ b/app-editors/vim-core/vim-core-9.0.1157.ebuild
@@ -31,6 +31,13 @@ IUSE="nls acl minimal"
DEPEND=">=sys-libs/ncurses-5.2-r2:0"
BDEPEND="sys-devel/autoconf"
+if [[ ${PV} != 9999* ]]; then
+ # Gentoo patches to fix runtime issues, cross-compile errors, etc
+ PATCHES=(
+ "${WORKDIR}/vim-patches-vim-${VIM_PATCHES_VERSION}-patches"
+ )
+fi
+
pkg_setup() {
# people with broken alphabets run into trouble. bug #82186.
unset LANG LC_ALL
@@ -38,10 +45,7 @@ pkg_setup() {
}
src_prepare() {
- if [[ ${PV} != 9999* ]] ; then
- # Gentoo patches to fix runtime issues, cross-compile errors, etc
- eapply "${WORKDIR}"/vim-patches-vim-${VIM_PATCHES_VERSION}-patches
- fi
+ default
# Fixup a script to use awk instead of nawk
sed -i \
@@ -106,8 +110,6 @@ src_prepare() {
# Remove src/auto/configure file.
rm -v src/auto/configure || die "rm configure failed"
-
- eapply_user
}
src_configure() {
diff --git a/app-editors/vim-core/vim-core-9999.ebuild b/app-editors/vim-core/vim-core-9999.ebuild
index df3192ffe27a..64e63ae0b84e 100644
--- a/app-editors/vim-core/vim-core-9999.ebuild
+++ b/app-editors/vim-core/vim-core-9999.ebuild
@@ -31,6 +31,13 @@ IUSE="nls acl minimal"
DEPEND=">=sys-libs/ncurses-5.2-r2:0"
BDEPEND="sys-devel/autoconf"
+if [[ ${PV} != 9999* ]]; then
+ # Gentoo patches to fix runtime issues, cross-compile errors, etc
+ PATCHES=(
+ "${WORKDIR}/vim-patches-vim-${VIM_PATCHES_VERSION}-patches"
+ )
+fi
+
pkg_setup() {
# people with broken alphabets run into trouble. bug #82186.
unset LANG LC_ALL
@@ -38,10 +45,7 @@ pkg_setup() {
}
src_prepare() {
- if [[ ${PV} != 9999* ]] ; then
- # Gentoo patches to fix runtime issues, cross-compile errors, etc
- eapply "${WORKDIR}"/vim-patches-vim-9.0.0049-patches
- fi
+ default
# Fixup a script to use awk instead of nawk
sed -i \
@@ -106,8 +110,6 @@ src_prepare() {
# Remove src/auto/configure file.
rm -v src/auto/configure || die "rm configure failed"
-
- eapply_user
}
src_configure() {