summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdel KARA SLIMANE <adel.ks@zegrapher.com>2021-06-13 16:39:50 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-06-15 16:03:06 +0300
commitf32fde974cc700d904353c494173b77a004f6ffb (patch)
tree640d69e0c2342c18e0da0b9957d253d40f26d4e9 /app-editors/vscodium
parentapp-editors/vscode: bump to 1.57.0 (diff)
downloadgentoo-f32fde974cc700d904353c494173b77a004f6ffb.tar.gz
gentoo-f32fde974cc700d904353c494173b77a004f6ffb.tar.bz2
gentoo-f32fde974cc700d904353c494173b77a004f6ffb.zip
app-editors/vscodium: bump to 1.57.0
Signed-off-by: Adel KARA SLIMANE <adel.ks@zegrapher.com> Closes: https://github.com/gentoo/gentoo/pull/21227 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-editors/vscodium')
-rw-r--r--app-editors/vscodium/Manifest3
-rw-r--r--app-editors/vscodium/vscodium-1.57.0.ebuild95
2 files changed, 98 insertions, 0 deletions
diff --git a/app-editors/vscodium/Manifest b/app-editors/vscodium/Manifest
index d652392dafc0..c2b418a07962 100644
--- a/app-editors/vscodium/Manifest
+++ b/app-editors/vscodium/Manifest
@@ -1,3 +1,6 @@
DIST vscodium-1.56.2-amd64.tar.gz 108032091 BLAKE2B e6d66885f79a8f29e9316cf759d6b562029a3da9c3fc6d14742adda0ae20e4be05b6c08f8c1698f3340cd0ca97836c49d3ef82bca9a27318d5f6d5e36555455d SHA512 831444221a3055fde829920ad6c0b8c007aa539b614918b20af0e676ecd31f341497f9c7fb8d8fe95f757bc360446cac93e00ee1a828183e0feb1eefad1e0c11
DIST vscodium-1.56.2-arm.tar.gz 96683293 BLAKE2B bdc6b89ebfa9e1be765aef63f8a2bcdbf2074b64d70833447b3a3caf148c7887c672077827b7467a681219eef0101bdf82581f589586a263397d2cc9951a8c0c SHA512 023c59d4ae6590437c9425fa02f70cd957c125ea69cfa1c4fe8812f2b7521b747421efe89fd3e4bd95b54f0bdea177941f72467af5d8036d51426b8139a48fc2
DIST vscodium-1.56.2-arm64.tar.gz 113358341 BLAKE2B f7f8c8589985edd11ba80b4fff9ab1174d436a2516eabc02cd6b3f5d03559295f3fe6772a16e6825d6a23953107b5b7537ab28cedc040a8b35a4b25182ee8d29 SHA512 f0aec2074e93bc26cfc615029bbc9ab360993f00a70272002982c058c7746824f6d97fffb34a5d6c16597b4ad8453730f28b04c11e4d0fd8ccea873490b260d5
+DIST vscodium-1.57.0-amd64.tar.gz 107752144 BLAKE2B c7f6f07a526e25b52f5a93eecdcf285f32bf5af38ff4e0b4882303078c110555134e37d85fad01d92970758e867e17e199586878a0a3abebd6fc18866d1c557a SHA512 e58d6161cff2ab0ef206ae629c65d03a947cc9112826a880f86c296d19462edf03e66c2d17399268b32aed597ea688f93b20cade8aac79d97871306c4d967073
+DIST vscodium-1.57.0-arm.tar.gz 96394761 BLAKE2B 3fc3ab8d4be7343cc8597cf9c09a13e1e28a1bfce12b19a11f5bdf46c1d6931c12718306f19c78fd7c567b622bf40434165009b0b0b6b9de3b86005833188511 SHA512 d7eb1776ceedd0072b039a04ec194779d6c27decc92d311cc9bd8c630b776ec1c85e46b8c3afe93c3cae904f27a2e05d69c6ca4155cae6a90c44570f59afedb2
+DIST vscodium-1.57.0-arm64.tar.gz 113075134 BLAKE2B eeead9b70a8e7b353ac744b65b3854ce5954f242a777e974ba4c8a586aa8c99d6dc5ee793e01568275a3edc48f8287ee3c3c8d1ae6b3c54b9df8913d4f32f96d SHA512 0c8a282b36ec3067246b590c241b3301a623cc9b0bd15bdbc3a2ad6303399c24bb721264ea69f4342717d8ad29046e6ed25ff6b3449923a315e2df2ccc85e0db
diff --git a/app-editors/vscodium/vscodium-1.57.0.ebuild b/app-editors/vscodium/vscodium-1.57.0.ebuild
new file mode 100644
index 000000000000..e25a3967ed49
--- /dev/null
+++ b/app-editors/vscodium/vscodium-1.57.0.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop pax-utils xdg
+
+DESCRIPTION="A community-driven, freely-licensed binary distribution of Microsoft's VSCode"
+HOMEPAGE="https://vscodium.com/"
+SRC_URI="
+ amd64? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-x64-${PV}.tar.gz -> ${P}-amd64.tar.gz )
+ arm? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-armhf-${PV}.tar.gz -> ${P}-arm.tar.gz )
+ arm64? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-arm64-${PV}.tar.gz -> ${P}-arm64.tar.gz )
+"
+
+RESTRICT="mirror strip bindist"
+
+LICENSE="
+ Apache-2.0
+ BSD
+ BSD-1
+ BSD-2
+ BSD-4
+ CC-BY-4.0
+ ISC
+ LGPL-2.1+
+ MIT
+ MPL-2.0
+ openssl
+ PYTHON
+ TextMate-bundle
+ Unlicense
+ UoI-NCSA
+ W3C
+"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~arm64"
+IUSE=""
+
+RDEPEND="
+ app-accessibility/at-spi2-atk
+ app-crypt/libsecret[crypt]
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/libpng:0/16
+ net-print/cups
+ x11-libs/cairo
+ x11-libs/gtk+:3
+ x11-libs/libnotify
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ x11-libs/libXScrnSaver
+ x11-libs/libXtst
+ x11-libs/pango
+"
+
+QA_PREBUILT="
+ /opt/vscodium/codium
+ /opt/vscodium/libEGL.so
+ /opt/vscodium/libffmpeg.so
+ /opt/vscodium/libGLESv2.so
+ /opt/vscodium/libvulkan.so*
+ /opt/vscodium/chrome-sandbox
+ /opt/vscodium/libvk_swiftshader.so
+ /opt/vscodium/swiftshader/libEGL.so
+ /opt/vscodium/swiftshader/libGLESv2.so
+ /opt/vscodium/resources/app/extensions/*
+ /opt/vscodium/resources/app/node_modules.asar.unpacked/*
+"
+
+S="${WORKDIR}"
+
+src_install() {
+ # Cleanup
+ rm "${S}/resources/app/LICENSE.txt" || die
+
+ # Install
+ pax-mark m codium
+ insinto "/opt/${PN}"
+ doins -r *
+ fperms +x /opt/${PN}/{,bin/}codium
+ fperms +x /opt/${PN}/chrome-sandbox
+ fperms -R +x /opt/${PN}/resources/app/out/vs/base/node
+ fperms +x /opt/${PN}/resources/app/node_modules.asar.unpacked/vscode-ripgrep/bin/rg
+ dosym "../../opt/${PN}/bin/codium" "usr/bin/vscodium"
+ domenu "${FILESDIR}/vscodium.desktop"
+ domenu "${FILESDIR}/vscodium-url-handler.desktop"
+ newicon "resources/app/resources/linux/code.png" "vscodium.png"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ elog "When compared to the regular VSCode, VSCodium has a few quirks"
+ elog "More information at: https://github.com/VSCodium/vscodium/blob/master/DOCS.md"
+}