summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-07-07 21:12:20 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-07-07 21:13:06 +0300
commite071babc8dbd6ef15a1c572f10cc20ce92d631d1 (patch)
tree1b794fcd94b4e83950480aa7d63b4cbbd4891160 /app-editors/vscode
parentvirtual/dist-kernel: Stabilize 6.1.38 amd64 arm64 ppc64 x86, #909777 (diff)
downloadgentoo-e071babc8dbd6ef15a1c572f10cc20ce92d631d1.tar.gz
gentoo-e071babc8dbd6ef15a1c572f10cc20ce92d631d1.tar.bz2
gentoo-e071babc8dbd6ef15a1c572f10cc20ce92d631d1.zip
app-editors/vscode: add 1.80.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-editors/vscode')
-rw-r--r--app-editors/vscode/Manifest3
-rw-r--r--app-editors/vscode/vscode-1.80.0.ebuild122
2 files changed, 125 insertions, 0 deletions
diff --git a/app-editors/vscode/Manifest b/app-editors/vscode/Manifest
index 5d667181c4a5..f4a2f696afb1 100644
--- a/app-editors/vscode/Manifest
+++ b/app-editors/vscode/Manifest
@@ -7,3 +7,6 @@ DIST vscode-1.79.1-arm64.tar.gz 130964437 BLAKE2B ae7d5a14a0d31de1ac984f74805191
DIST vscode-1.79.2-amd64.tar.gz 134757908 BLAKE2B 8f92476935a7833cbb872d41b65d480540860a529f587009e1188d3aaa1dc61b19ca11ee472ebf7942d5f763bee940fb28b4066a67346094aa5efd519456fd5c SHA512 14aded59f7b083a1c57c50ff24064c242520c6520811541f5cd4daa9ab3878eae4a88c8e0ba54bfe3ec1023395e5b2f4f74cecd373d8bc43acbdb15fdd1fc47f
DIST vscode-1.79.2-arm.tar.gz 119307976 BLAKE2B 89b48809c3306ff89057f7533c825bfce9f35792be4b308b254bc4e347ead14c3e89a00c70ce678287e2e8376a76997c4a43dbb4dd3209cfaebe4a432d5a0bfc SHA512 9f83a0ae95fb6fead3fe2da3ce96e6be336713a29bd28fa0db168ce3236d4eaf80067e9ca1ff0cd3ebb7d31d9789f262a0119524afe042f75b58bcb953937ca5
DIST vscode-1.79.2-arm64.tar.gz 130972979 BLAKE2B da5c86ac8bfe4d7900aec6dbd61de03555e94a8c36ca504024b5fa0c217f2473fc13a1e0ef0fa32779ae0793f6574fceae693381370b068d574bc0d1fa8649e0 SHA512 76050ff4fd73a3cc285781f03c087388d8717d5fbb31807f271da9bca77d10ac909844dc9ec1b30e85dd5a76a76ac5b027d200acf0d4445c5d5fb88bdea1104a
+DIST vscode-1.80.0-amd64.tar.gz 135325602 BLAKE2B f959c454f0a0fbf3f499eebfbc48115347e88619e44d0ceb68844e23e15991627651b2d63c0b7f756decefee9e535f39d3ca4a0292523af541c4c1b035f339fa SHA512 b121229bb9c7ed467370a00abb5efc53b8999cade79351c9740037df4af5485714c4695905e228e1e483f69c30e84ec7182ad249431d68f5d3aaacaf6ac2c44d
+DIST vscode-1.80.0-arm.tar.gz 119949287 BLAKE2B 56b20d79aacf3effd36f811c25fcb56e80df03a18026ddb13de62ef06aad13d92bdb93739f330bd212007023ef75f4be99616f945569755d733ab97af8757231 SHA512 ea98b06a0adbe097436a9c154c9083442426128105c40ebeb73408471822102f9b977985ed50cedb056d0a4ab9578415509f2a558fbdd901d9a230a1cd267f4d
+DIST vscode-1.80.0-arm64.tar.gz 131637682 BLAKE2B e8e50dba908b288ee359d97d378ce8ff36f4c82d3fa4f101a2c9d335641b6d121cddd5dff8f6f233defa8234fff880d2a3c8a006e069612e511d5fed90b4df0c SHA512 233a380270f043dbe5b045188f7c28731325be6705a0365f1d297240f8a0e77876189685cf7e93f60e52617524c65cf5b6c9390ecb8e01e266c6bced31680941
diff --git a/app-editors/vscode/vscode-1.80.0.ebuild b/app-editors/vscode/vscode-1.80.0.ebuild
new file mode 100644
index 000000000000..0362e867fb48
--- /dev/null
+++ b/app-editors/vscode/vscode-1.80.0.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop pax-utils xdg optfeature
+
+DESCRIPTION="Multiplatform Visual Studio Code from Microsoft"
+HOMEPAGE="https://code.visualstudio.com"
+SRC_URI="
+ amd64? ( https://update.code.visualstudio.com/${PV}/linux-x64/stable -> ${P}-amd64.tar.gz )
+ arm? ( https://update.code.visualstudio.com/${PV}/linux-armhf/stable -> ${P}-arm.tar.gz )
+ arm64? ( https://update.code.visualstudio.com/${PV}/linux-arm64/stable -> ${P}-arm64.tar.gz )
+"
+S="${WORKDIR}"
+
+RESTRICT="mirror strip bindist"
+
+LICENSE="
+ Apache-2.0
+ BSD
+ BSD-1
+ BSD-2
+ BSD-4
+ CC-BY-4.0
+ ISC
+ LGPL-2.1+
+ Microsoft-vscode
+ MIT
+ MPL-2.0
+ openssl
+ PYTHON
+ TextMate-bundle
+ Unlicense
+ UoI-NCSA
+ W3C
+"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~arm64"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ app-crypt/libsecret[crypt]
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/mesa
+ net-print/cups
+ sys-apps/util-linux
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libxshmfence
+ x11-libs/pango
+"
+
+QA_PREBUILT="
+ /opt/vscode/bin/code-tunnel
+ /opt/vscode/chrome_crashpad_handler
+ /opt/vscode/chrome-sandbox
+ /opt/vscode/code
+ /opt/vscode/libEGL.so
+ /opt/vscode/libffmpeg.so
+ /opt/vscode/libGLESv2.so
+ /opt/vscode/libvk_swiftshader.so
+ /opt/vscode/libvulkan.so*
+ /opt/vscode/resources/app/extensions/*
+ /opt/vscode/resources/app/node_modules.asar.unpacked/*
+ /opt/vscode/swiftshader/libEGL.so
+ /opt/vscode/swiftshader/libGLESv2.so
+"
+
+src_install() {
+ if use amd64; then
+ cd "${WORKDIR}/VSCode-linux-x64" || die
+ elif use arm; then
+ cd "${WORKDIR}/VSCode-linux-armhf" || die
+ elif use arm64; then
+ cd "${WORKDIR}/VSCode-linux-arm64" || die
+ else
+ die "Visual Studio Code only supports amd64, arm and arm64"
+ fi
+
+ # Cleanup
+ rm -r ./resources/app/ThirdPartyNotices.txt || die
+
+ # Disable update server
+ sed -e "/updateUrl/d" -i ./resources/app/product.json || die
+
+ # Install
+ pax-mark m code
+ mkdir -p "${ED}/opt/${PN}" || die
+ cp -r . "${ED}/opt/${PN}" || die
+ fperms 4711 /opt/${PN}/chrome-sandbox
+
+ dosym -r "/opt/${PN}/bin/code" "usr/bin/vscode"
+ dosym -r "/opt/${PN}/bin/code" "usr/bin/code"
+ dosym -r "/opt/${PN}/bin/code-tunnel" "usr/bin/code-tunnel"
+ domenu "${FILESDIR}/vscode.desktop"
+ domenu "${FILESDIR}/vscode-url-handler.desktop"
+ domenu "${FILESDIR}/vscode-wayland.desktop"
+ domenu "${FILESDIR}/vscode-url-handler-wayland.desktop"
+ newicon "resources/app/resources/linux/code.png" "vscode.png"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ optfeature "keyring support inside vscode" "gnome-base/gnome-keyring"
+}