summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2025-01-01 14:13:14 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2025-01-01 17:47:44 +0100
commit7c0c9c5f14d5d388e74c857c64b9f867caeb8aeb (patch)
tree7b16fd77f006a7115c20cb44be7c602ea0d2558b /app-editors/tea
parentapp-editors/tea: Drop IUSE qt5 (make Qt6 non-optional) (diff)
downloadgentoo-7c0c9c5f14d5d388e74c857c64b9f867caeb8aeb.tar.gz
gentoo-7c0c9c5f14d5d388e74c857c64b9f867caeb8aeb.tar.bz2
gentoo-7c0c9c5f14d5d388e74c857c64b9f867caeb8aeb.zip
app-editors/tea: drop 62.4.0
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-editors/tea')
-rw-r--r--app-editors/tea/tea-62.4.0.ebuild83
1 files changed, 0 insertions, 83 deletions
diff --git a/app-editors/tea/tea-62.4.0.ebuild b/app-editors/tea/tea-62.4.0.ebuild
deleted file mode 100644
index d966ed1501ae..000000000000
--- a/app-editors/tea/tea-62.4.0.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake xdg
-
-MY_P="tea-qt-${PV}"
-
-DESCRIPTION="Small, lightweight Qt text editor"
-HOMEPAGE="https://tea.ourproject.org/"
-SRC_URI="https://github.com/psemiletov/tea-qt/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="amd64 ~riscv x86"
-IUSE="aspell djvu qt6 pdf"
-
-RESTRICT="test" # no tests
-
-DEPEND="
- app-text/hunspell:=
- sys-libs/zlib
- aspell? ( app-text/aspell )
- djvu? ( app-text/djvu )
- qt6? (
- dev-qt/qtbase:6[widgets]
- dev-qt/qt5compat:6
- pdf? ( app-text/poppler:=[qt6(-)] )
- )
- !qt6? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
- pdf? ( app-text/poppler:=[qt5] )
- )
-"
-RDEPEND="${DEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-DOCS=( AUTHORS ChangeLog NEWS NEWS-RU TODO )
-
-PATCHES=(
- "${FILESDIR}/tea-62.1.1-fix-desktop.patch"
-)
-
-src_prepare() {
- cmake_src_prepare
-
- # Replace AUR link with p.g.o link
- sed -i \
- -e 's,AUR: aur.archlinux.org/packages/tea-qt-git,Gentoo: https://packages.gentoo.org/packages/app-editors/tea,' \
- tea.cpp translations/{de,es,fr,pl,ru}.ts || die
-
- # Rename tea to tea-qt to avoid file conflict with dev-util/tea
- # bug #917587
- # https://github.com/psemiletov/tea-qt/issues/50
- sed -i -e '/set_target_properties(tea PROPERTIES$/ a\
- OUTPUT_NAME \"tea-qt\"' \
- CMakeLists.txt || die
- sed -i -e '/Exec/ { s/tea/tea-qt/ }' desktop/tea.desktop || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DUSE_ASPELL=$(usex aspell)
- -DUSE_PDF=$(usex pdf)
- -DUSE_DJVU=$(usex djvu)
- -DUSE_PRINTER=OFF # appears to be setup wrong
- $(cmake_use_find_package qt6 Qt6)
- )
-
- cmake_src_configure
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
-
- if [[ "${REPLACING_VERSIONS}" == "47.0.0" ]]; then
- elog "Executable 'tea' has been renamed to 'tea-qt'"
- fi
-}