summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-17 01:48:22 +0000
committerSam James <sam@gentoo.org>2022-05-17 05:33:50 +0000
commit542edce19adc5c8d219224f56d861fa5a08ff9d7 (patch)
treeb3cf931c825e876ffaeb7236facf425d0ccc5313 /app-editors/scite
parentapp-crypt/pinentry: [QA] drop (very) stale GCC version checks (diff)
downloadgentoo-542edce19adc5c8d219224f56d861fa5a08ff9d7.tar.gz
gentoo-542edce19adc5c8d219224f56d861fa5a08ff9d7.tar.bz2
gentoo-542edce19adc5c8d219224f56d861fa5a08ff9d7.zip
app-editors/scite: [QA] drop (very) stale GCC version checks
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors/scite')
-rw-r--r--app-editors/scite/scite-5.1.1.ebuild20
-rw-r--r--app-editors/scite/scite-5.1.3.ebuild20
-rw-r--r--app-editors/scite/scite-5.1.6.ebuild20
3 files changed, 3 insertions, 57 deletions
diff --git a/app-editors/scite/scite-5.1.1.ebuild b/app-editors/scite/scite-5.1.1.ebuild
index c3e280ecf802..55863b5a601e 100644
--- a/app-editors/scite/scite-5.1.1.ebuild
+++ b/app-editors/scite/scite-5.1.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -36,24 +36,6 @@ DOCS=("../README")
S="${WORKDIR}/${PN}/gtk"
-pkg_pretend() {
- if tc-is-clang ; then
- # need c++17 features
- [[ "${MERGE_TYPE}" != "binary" &&
- $(clang-major-version) -lt 5 ]] &&
- die "Sorry, SCiTE uses C++17 Features and needs >sys-devel/clang-5
- ($(clang-major-version))."
-
- elif tc-is-gcc; then
- # older gcc is not supported
- [[ "${MERGE_TYPE}" != "binary" &&
- $(gcc-major-version) -lt 7 ]] &&
- die "Sorry, Scite uses C++17 Features, need >sys-devel/gcc-7."
- else
- die "Either gcc or clang should be configured for building scite"
- fi
-}
-
pkg_setup() {
use lua && lua-single_pkg_setup
}
diff --git a/app-editors/scite/scite-5.1.3.ebuild b/app-editors/scite/scite-5.1.3.ebuild
index 3defc2beced6..56eaa7f3c945 100644
--- a/app-editors/scite/scite-5.1.3.ebuild
+++ b/app-editors/scite/scite-5.1.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -36,24 +36,6 @@ DOCS=("../README")
S="${WORKDIR}/${PN}/gtk"
-pkg_pretend() {
- if tc-is-clang ; then
- # need c++17 features
- [[ "${MERGE_TYPE}" != "binary" &&
- $(clang-major-version) -lt 5 ]] &&
- die "Sorry, SCiTE uses C++17 Features and needs >sys-devel/clang-5
- ($(clang-major-version))."
-
- elif tc-is-gcc; then
- # older gcc is not supported
- [[ "${MERGE_TYPE}" != "binary" &&
- $(gcc-major-version) -lt 7 ]] &&
- die "Sorry, Scite uses C++17 Features, need >sys-devel/gcc-7."
- else
- die "Either gcc or clang should be configured for building scite"
- fi
-}
-
pkg_setup() {
use lua && lua-single_pkg_setup
}
diff --git a/app-editors/scite/scite-5.1.6.ebuild b/app-editors/scite/scite-5.1.6.ebuild
index f04689f90329..f2887e4b0f91 100644
--- a/app-editors/scite/scite-5.1.6.ebuild
+++ b/app-editors/scite/scite-5.1.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -36,24 +36,6 @@ DOCS=("../README")
S="${WORKDIR}/${PN}/gtk"
-pkg_pretend() {
- if tc-is-clang ; then
- # need c++17 features
- [[ "${MERGE_TYPE}" != "binary" &&
- $(clang-major-version) -lt 5 ]] &&
- die "Sorry, SCiTE uses C++17 Features and needs >sys-devel/clang-5
- ($(clang-major-version))."
-
- elif tc-is-gcc; then
- # older gcc is not supported
- [[ "${MERGE_TYPE}" != "binary" &&
- $(gcc-major-version) -lt 7 ]] &&
- die "Sorry, Scite uses C++17 Features, need >sys-devel/gcc-7."
- else
- die "Either gcc or clang should be configured for building scite"
- fi
-}
-
pkg_setup() {
use lua && lua-single_pkg_setup
}