summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-01-13 20:29:51 -0500
committerTim Harder <radhermit@gentoo.org>2016-01-13 20:34:42 -0500
commit7012efe0533427e3987e122bef2d6f186ab8fe0f (patch)
treeb7b428aa82bf30db914ecca884b25c7787971e63 /app-editors/gvim/gvim-9999.ebuild
parentapp-editors/vim: version bump to 7.4.1089 (diff)
downloadgentoo-7012efe0533427e3987e122bef2d6f186ab8fe0f.tar.gz
gentoo-7012efe0533427e3987e122bef2d6f186ab8fe0f.tar.bz2
gentoo-7012efe0533427e3987e122bef2d6f186ab8fe0f.zip
app-editors/gvim: version bump to 7.4.1089
Diffstat (limited to 'app-editors/gvim/gvim-9999.ebuild')
-rw-r--r--app-editors/gvim/gvim-9999.ebuild19
1 files changed, 3 insertions, 16 deletions
diff --git a/app-editors/gvim/gvim-9999.ebuild b/app-editors/gvim/gvim-9999.ebuild
index 505f21966df8..0d1e8a3dfbe8 100644
--- a/app-editors/gvim/gvim-9999.ebuild
+++ b/app-editors/gvim/gvim-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
VIM_VERSION="7.4"
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
PYTHON_REQ_USE=threads
inherit eutils vim-doc flag-o-matic fdo-mime versionator bash-completion-r1 prefix python-r1
@@ -63,7 +63,7 @@ RDEPEND="
perl? ( dev-lang/perl:= )
python? ( ${PYTHON_DEPS} )
racket? ( dev-scheme/racket )
- ruby? ( || ( dev-lang/ruby:2.2 dev-lang/ruby:2.1 dev-lang/ruby:2.0 ) )
+ ruby? ( || ( dev-lang/ruby:2.3 dev-lang/ruby:2.2 dev-lang/ruby:2.1 dev-lang/ruby:2.0 ) )
selinux? ( sys-libs/libselinux )
session? ( x11-libs/libSM )
tcl? ( dev-lang/tcl:0= )
@@ -385,19 +385,6 @@ pkg_postinst() {
# Update fdo mime stuff, bug #78394
fdo-mime_mime_database_update
- if [[ -z ${REPLACING_VERSIONS} ]] ; then
- echo
- elog "Vim 7 includes an integrated spell checker. You need to install"
- elog "word list files before you can use it. There are ebuilds for"
- elog "some of these named app-vim/vim-spell-*. If your language of"
- elog "choice is not included, please consult vim-spell.eclass for"
- elog "instructions on how to make a package."
- echo
- ewarn "Note that the English word lists are no longer installed by"
- ewarn "default."
- echo
- fi
-
# Make convenience symlinks
update_vim_symlinks
}