summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2024-02-25 09:40:24 +0100
committerUlrich Müller <ulm@gentoo.org>2024-02-25 09:42:33 +0100
commit5cadb75c92dcd146c598497e0a601a77476bfee3 (patch)
tree1d04d191f28bc5455be7b5c8d8831d9a7a674b75 /app-editors/emacs
parentsys-apps/portage: add 3.0.63 (diff)
downloadgentoo-5cadb75c92dcd146c598497e0a601a77476bfee3.tar.gz
gentoo-5cadb75c92dcd146c598497e0a601a77476bfee3.tar.bz2
gentoo-5cadb75c92dcd146c598497e0a601a77476bfee3.zip
app-editors/emacs: Shorten socket paths for gnupg
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-editors/emacs')
-rw-r--r--app-editors/emacs/emacs-29.2-r1.ebuild8
-rw-r--r--app-editors/emacs/emacs-29.2.9999.ebuild8
-rw-r--r--app-editors/emacs/emacs-30.0.9999.ebuild8
3 files changed, 12 insertions, 12 deletions
diff --git a/app-editors/emacs/emacs-29.2-r1.ebuild b/app-editors/emacs/emacs-29.2-r1.ebuild
index 0c5599307ee4..e6d111a23c30 100644
--- a/app-editors/emacs/emacs-29.2-r1.ebuild
+++ b/app-editors/emacs/emacs-29.2-r1.ebuild
@@ -452,11 +452,11 @@ src_test() {
# Redirect GnuPG's sockets, in order not to exceed the 108 char limit
# for socket paths on Linux.
- mkdir "${T}"/gnupg || die
+ mkdir "${T}"/gpg || die
local f
- for f in S.gpg-agent{,.browser,.extra,.ssh}; do
- printf "%%Assuan%%\nsocket=%s\n" "${T}/gnupg/${f}" \
- > "test/lisp/gnus/mml-sec-resources/${f}" || die
+ for f in browser extra ssh; do
+ printf "%%Assuan%%\nsocket=%s\n" "${T}/gpg/S.${f}" \
+ > "test/lisp/gnus/mml-sec-resources/S.gpg-agent.${f}" || die
done
# See test/README for possible options
diff --git a/app-editors/emacs/emacs-29.2.9999.ebuild b/app-editors/emacs/emacs-29.2.9999.ebuild
index e478453357b9..61a66215f0bc 100644
--- a/app-editors/emacs/emacs-29.2.9999.ebuild
+++ b/app-editors/emacs/emacs-29.2.9999.ebuild
@@ -449,11 +449,11 @@ src_test() {
# Redirect GnuPG's sockets, in order not to exceed the 108 char limit
# for socket paths on Linux.
- mkdir "${T}"/gnupg || die
+ mkdir "${T}"/gpg || die
local f
- for f in S.gpg-agent{,.browser,.extra,.ssh}; do
- printf "%%Assuan%%\nsocket=%s\n" "${T}/gnupg/${f}" \
- > "test/lisp/gnus/mml-sec-resources/${f}" || die
+ for f in browser extra ssh; do
+ printf "%%Assuan%%\nsocket=%s\n" "${T}/gpg/S.${f}" \
+ > "test/lisp/gnus/mml-sec-resources/S.gpg-agent.${f}" || die
done
# See test/README for possible options
diff --git a/app-editors/emacs/emacs-30.0.9999.ebuild b/app-editors/emacs/emacs-30.0.9999.ebuild
index f1c545bffd0b..89bb695cbae2 100644
--- a/app-editors/emacs/emacs-30.0.9999.ebuild
+++ b/app-editors/emacs/emacs-30.0.9999.ebuild
@@ -451,11 +451,11 @@ src_test() {
# Redirect GnuPG's sockets, in order not to exceed the 108 char limit
# for socket paths on Linux.
- mkdir "${T}"/gnupg || die
+ mkdir "${T}"/gpg || die
local f
- for f in S.gpg-agent{,.browser,.extra,.ssh}; do
- printf "%%Assuan%%\nsocket=%s\n" "${T}/gnupg/${f}" \
- > "test/lisp/gnus/mml-sec-resources/${f}" || die
+ for f in browser extra ssh; do
+ printf "%%Assuan%%\nsocket=%s\n" "${T}/gpg/S.${f}" \
+ > "test/lisp/gnus/mml-sec-resources/S.gpg-agent.${f}" || die
done
# See test/README for possible options