summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2021-06-03 00:07:07 +0200
committerRémi Cardona <remi@gentoo.org>2021-06-03 00:14:52 +0200
commite16785f31d7db73b55b4f57b36cec94192444669 (patch)
tree959025b7bf2b5f3662463c760586ead4949297dd /app-dicts/verbiste
parentapp-crypt/acme-sh: drop old version (diff)
downloadgentoo-e16785f31d7db73b55b4f57b36cec94192444669.tar.gz
gentoo-e16785f31d7db73b55b4f57b36cec94192444669.tar.bz2
gentoo-e16785f31d7db73b55b4f57b36cec94192444669.zip
app-dicts/verbiste: bump to 0.1.47
Closes: https://bugs.gentoo.org/786876 Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Rémi Cardona <remi@gentoo.org>
Diffstat (limited to 'app-dicts/verbiste')
-rw-r--r--app-dicts/verbiste/Manifest1
-rw-r--r--app-dicts/verbiste/verbiste-0.1.47.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/app-dicts/verbiste/Manifest b/app-dicts/verbiste/Manifest
index b8e4ece9defe..4c1f7c52b8d4 100644
--- a/app-dicts/verbiste/Manifest
+++ b/app-dicts/verbiste/Manifest
@@ -1 +1,2 @@
DIST verbiste-0.1.44.tar.gz 780465 BLAKE2B 692fd3bdf00323b08d4c8a66baaf9f6800c4593428d36efb4cd4bfc51eea912297154e4b0610b94b66d1354317ac7cf24d6dca083d521c648338a0974f6d0899 SHA512 36c8a2af31f948dc3970bef260d5cd7f9d230f4966f846bcc823f006cd98ab98229544b7470466529344ac5735d1189c859c539f526cd58410d9a521510db5e5
+DIST verbiste-0.1.47.tar.gz 781085 BLAKE2B 39f92bffc2165b49a2cd66ced4337aa4eb4253a1d767f0c26cea0bc10e965a5547158ab0de796b76016fd46bd220b305a14c9be42b76f5a25f0fde85e4ff1b97 SHA512 cc06d3e4a09b9edf2fe3996f527ae05fa50af909cc5ea6ed830d1b4f5706cf9b29028160cff842a211148e13d736f7e2cb74f10b3c5fd84d93a1038e05a26cbf
diff --git a/app-dicts/verbiste/verbiste-0.1.47.ebuild b/app-dicts/verbiste/verbiste-0.1.47.ebuild
new file mode 100644
index 000000000000..dc372435661b
--- /dev/null
+++ b/app-dicts/verbiste/verbiste-0.1.47.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop xdg-utils
+
+DESCRIPTION="French conjugation system"
+HOMEPAGE="http://sarrazip.com/dev/verbiste.html"
+SRC_URI="http://sarrazip.com/dev/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gtk"
+
+RDEPEND="
+ >=dev-libs/libxml2-2.4.0:2
+ gtk? ( >=x11-libs/gtk+-2.6:2 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ econf \
+ --with-console-app \
+ --without-gnome-app \
+ --without-gnome-applet \
+ $(use_with gtk gtk-app)
+}
+
+src_install() {
+ default
+
+ dodoc HACKING LISEZMOI
+ # file is only installed with USE=gnome
+ if use gtk; then
+ sed -e 's/Exec=.*/Exec=verbiste-gtk/' \
+ -i src/gnome/verbiste.desktop || die
+ domenu src/gnome/verbiste.desktop
+ fi
+
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ if use gtk; then
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ fi
+}
+
+pkg_postrm() {
+ if use gtk; then
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ fi
+}