summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZ. Liu <zhixu.liu@gmail.com>2024-08-23 17:53:00 +0800
committerSam James <sam@gentoo.org>2024-12-11 06:11:36 +0000
commita8d7107541ad5b19d5f2a19561dd48ff7201fcf1 (patch)
treec2cf97bcc0865ff525708806f155e754ee28019a /app-crypt/cfssl
parentnet-irc/ngircd: crank copyright (diff)
downloadgentoo-a8d7107541ad5b19d5f2a19561dd48ff7201fcf1.tar.gz
gentoo-a8d7107541ad5b19d5f2a19561dd48ff7201fcf1.tar.bz2
gentoo-a8d7107541ad5b19d5f2a19561dd48ff7201fcf1.zip
app-crypt/cfssl: rename mkbundle to mkbundle.cfssl
mkbundle in cfssl is collided with dev-lang/mono, so we rename mkbundle to mkbundle.cfssl. Closes: https://bugs.gentoo.org/614364 Signed-off-by: Z. Liu <zhixu.liu@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/38259 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-crypt/cfssl')
-rw-r--r--app-crypt/cfssl/cfssl-1.4.1-r1.ebuild (renamed from app-crypt/cfssl/cfssl-1.4.1.ebuild)8
-rw-r--r--app-crypt/cfssl/cfssl-1.6.4-r1.ebuild (renamed from app-crypt/cfssl/cfssl-1.6.4.ebuild)8
2 files changed, 12 insertions, 4 deletions
diff --git a/app-crypt/cfssl/cfssl-1.4.1.ebuild b/app-crypt/cfssl/cfssl-1.4.1-r1.ebuild
index 7541ce49e832..d9a5facf5a3f 100644
--- a/app-crypt/cfssl/cfssl-1.4.1.ebuild
+++ b/app-crypt/cfssl/cfssl-1.4.1-r1.ebuild
@@ -14,8 +14,6 @@ SLOT="0"
KEYWORDS="amd64"
IUSE="hardened"
-RDEPEND="!!dev-lang/mono" #File collision (bug 614364)
-
PATCHES=(
"${FILESDIR}/${P}-build-fix.patch"
)
@@ -30,4 +28,10 @@ src_compile() {
src_install() {
dobin bin/*
dodoc CHANGELOG README.md
+ mv -iv "${ED}"/usr/bin/mkbundle{,.cfssl} || die
+}
+
+pkg_postinst() {
+ ewarn "Please note that mkbundle is renamed to mkbundle.cfssl, to avoid"
+ ewarn "collision with mkbundle in dev-lang/mono"
}
diff --git a/app-crypt/cfssl/cfssl-1.6.4.ebuild b/app-crypt/cfssl/cfssl-1.6.4-r1.ebuild
index 3d244721ab37..83786737696b 100644
--- a/app-crypt/cfssl/cfssl-1.6.4.ebuild
+++ b/app-crypt/cfssl/cfssl-1.6.4-r1.ebuild
@@ -14,8 +14,6 @@ SLOT="0"
KEYWORDS="~amd64 ~arm64"
IUSE="hardened"
-RDEPEND="!!dev-lang/mono" #File collision (bug 614364)
-
PATCHES=(
"${FILESDIR}/${PN}-1.4.1-build-fix.patch"
)
@@ -30,4 +28,10 @@ src_compile() {
src_install() {
dobin bin/*
dodoc CHANGELOG README.md
+ mv -iv "${ED}"/usr/bin/mkbundle{,.cfssl} || die
+}
+
+pkg_postinst() {
+ ewarn "Please note that mkbundle is renamed to mkbundle.cfssl, to avoid"
+ ewarn "collision with mkbundle in dev-lang/mono"
}