summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Levermann <simon@slevermann.de>2017-02-02 16:08:19 +0100
committerThomas Deutschmann <whissi@gentoo.org>2017-02-02 16:08:42 +0100
commit3b52a51234c375a7c39b3299f94026226559db27 (patch)
tree25a557686322ba4ed2c07948604f66dc9858962a /app-crypt/argon2/files
parentsys-devel/lld: Re-enable tests in the live ebuild (diff)
downloadgentoo-3b52a51234c375a7c39b3299f94026226559db27.tar.gz
gentoo-3b52a51234c375a7c39b3299f94026226559db27.tar.bz2
gentoo-3b52a51234c375a7c39b3299f94026226559db27.zip
app-crypt/argon2: version bump
Closes: https://github.com/gentoo/gentoo/pull/3644 Package-Manager: Portage-2.3.3, Repoman-2.3.1 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'app-crypt/argon2/files')
-rw-r--r--app-crypt/argon2/files/argon2-20161029-makefile-soname-symlinks.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-crypt/argon2/files/argon2-20161029-makefile-soname-symlinks.patch b/app-crypt/argon2/files/argon2-20161029-makefile-soname-symlinks.patch
new file mode 100644
index 000000000000..11892de11158
--- /dev/null
+++ b/app-crypt/argon2/files/argon2-20161029-makefile-soname-symlinks.patch
@@ -0,0 +1,28 @@
+diff --git a/Makefile b/Makefile
+index 1838c13..85aa710 100644
+--- a/Makefile
++++ b/Makefile
+@@ -87,8 +87,10 @@ endif
+ endif
+
+ LIB_SH := lib$(LIB_NAME).$(LIB_EXT)
++LIB_SH_VERSION := $(LIB_SH).0
+ LIB_ST := lib$(LIB_NAME).a
+ LIBRARIES = $(LIB_SH) $(LIB_ST)
++INSTALL_LIBRARIES = $(LIBRARIES) $(LIB_SH_VERSION)
+ HEADERS = include/argon2.h
+
+ INSTALL = install
+@@ -153,9 +155,11 @@ format:
+ -i include/*.h src/*.c src/*.h src/blake2/*.c src/blake2/*.h
+
+ install: $(RUN) libs
++ mv $(LIB_SH) $(LIB_SH_VERSION)
++ ln -sf $(LIB_SH_VERSION) $(LIB_SH)
+ $(INSTALL) -d $(INST_INCLUDE)
+ $(INSTALL) $(HEADERS) $(INST_INCLUDE)
+ $(INSTALL) -d $(INST_LIBRARY)
+- $(INSTALL) $(LIBRARIES) $(INST_LIBRARY)
++ $(INSTALL) $(INSTALL_LIBRARIES) $(INST_LIBRARY)
+ $(INSTALL) -d $(INST_BINARY)
+ $(INSTALL) $(RUN) $(INST_BINARY)