summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-02-21 21:51:15 -0600
committerWilliam Hubbs <williamh@gentoo.org>2023-02-21 21:51:15 -0600
commit7b84c7ce6d7b8d961ceff3b705b4c5dfc14a5ec5 (patch)
tree6cc1fdac7abeaa921c4d2867e9c50c4e1a0aab12 /app-backup/restic
parentdev-util/src-cli: drop 3.37.0, 3.38.0, 3.43.0 (diff)
downloadgentoo-7b84c7ce6d7b8d961ceff3b705b4c5dfc14a5ec5.tar.gz
gentoo-7b84c7ce6d7b8d961ceff3b705b4c5dfc14a5ec5.tar.bz2
gentoo-7b84c7ce6d7b8d961ceff3b705b4c5dfc14a5ec5.zip
app-backup/restic: add 0.15.1
Closes: https://bugs.gentoo.org/894182 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-backup/restic')
-rw-r--r--app-backup/restic/Manifest2
-rw-r--r--app-backup/restic/restic-0.15.1.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/app-backup/restic/Manifest b/app-backup/restic/Manifest
index 82a755f842db..5c68a94e623f 100644
--- a/app-backup/restic/Manifest
+++ b/app-backup/restic/Manifest
@@ -2,3 +2,5 @@ DIST restic-0.13.1-deps.tar.xz 179648640 BLAKE2B 5ba9663a95ccc3a1c41b88e44704e74
DIST restic-0.13.1.tar.gz 23855387 BLAKE2B e10fb1920ab62ba2116b8a7b9676c537c93fe2e8743a9ce6748b412d11fcf611deb368c0db1b0855b71fbac260930c86dc510ee149c09692eb93bf6e1830d0d6 SHA512 14feb6d0b3d258783d55ad537d8ccbdc9574a966e14f65465c132eceb92c821f4033428eba83acb1e1a9cfb169cc5fdc86b6ae90b94fe2855bd1f69262e30770
DIST restic-0.14.0-deps.tar.xz 226627460 BLAKE2B e97fe4b68b4216fa01449aff7a8df8d3ef91d64d97f07930740fdfbd0ead5099e2a732a36613db85104611a993926e10043ae35eddd19248303e17352ab9681f SHA512 6b89be07baaf080c287b51163e41d1e659df8e844d75a801df49e0062db872b4ab7d03ec617047e34aa8b0d2912fe384053c0de2c9ab282f1c80c88a07fda81a
DIST restic-0.14.0.tar.gz 23902279 BLAKE2B 21586b48e55de53b19c4f4d368167c69e3050cff41ae85a6fcdb3171ac71a38987b8b578de2e9e37bac9a531d364432610b9ecb316b3c93133fa07ccac5664f3 SHA512 d896c93b72790ba5b3c3cd71b68bb45682a12661067cd0d7370b6dfe6d4482988462c4243b5c0b412e5444784568f0375c5a01d43d4d0557d5e6bf01ca512157
+DIST restic-0.15.1-deps.tar.xz 156200684 BLAKE2B 8b34551c12e9b57d0e3328dd656f69d95964f4128eb61b1e546b1a002fd37874ee7614a9563754260d3b7ec0caf349fa611cb0316c5c5f983ba95d3607d6cae9 SHA512 4b2d9c9f6b43bd558965396f5ca501d57298ac444bf715801d52a743424a8e87b979c5808c599a6c13015e4e57a57e7911d86e77b2232cfa0c05822616f8ce9d
+DIST restic-0.15.1.tar.gz 23920501 BLAKE2B 9561211576c01707691a1d0d7575c6bcd0d8f3c691159d10281ecb1cce5d16f237d60fd2f998bf7ad41d2ad7f8e69fd92ce6d487769774d41bae7f5ebd0ee4d7 SHA512 54b982f87f60df506c293df12813bea2f8a0df8996453096565a0eaba2832791a35da288c2e9fac590a0eaee9aef52b2c968ee717457fab30a1974d00d1d73fe
diff --git a/app-backup/restic/restic-0.15.1.ebuild b/app-backup/restic/restic-0.15.1.ebuild
new file mode 100644
index 000000000000..e3954a106e68
--- /dev/null
+++ b/app-backup/restic/restic-0.15.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 go-module
+
+DESCRIPTION="A backup program that is fast, efficient and secure"
+HOMEPAGE="https://restic.github.io/"
+SRC_URI="https://github.com/restic/restic/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 LGPL-3-with-linking-exception MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="sys-fs/fuse:0"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ local mygoargs=(
+ -tags release
+ -ldflags "-X main.version=${PV}"
+ -asmflags "-trimpath=${S}"
+ -gcflags "-trimpath=${S}"
+ )
+
+ ego build "${mygoargs[@]}" -o restic ./cmd/restic
+}
+
+src_test() {
+ ego test -timeout 30m ./cmd/... ./internal/...
+}
+
+src_install() {
+ dobin restic
+
+ newbashcomp doc/bash-completion.sh "${PN}"
+
+ insinto /usr/share/zsh/site-functions
+ newins doc/zsh-completion.zsh _restic
+
+ doman doc/man/*
+ dodoc doc/*.rst
+}