summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Zander <negril.nx+gentoo@gmail.com>2024-08-14 17:19:04 +0200
committerSam James <sam@gentoo.org>2024-08-25 16:39:58 +0100
commitd459cd74b963c1865c26b90cefe7701f4b72c5bb (patch)
treec5345ca33471ccffdee0d5c24e702cd70eac1501 /app-arch/libdeflate
parentdev-debug/apitrace: 9.0-r5 Fix compilation on GCC 15 (diff)
downloadgentoo-d459cd74b963c1865c26b90cefe7701f4b72c5bb.tar.gz
gentoo-d459cd74b963c1865c26b90cefe7701f4b72c5bb.tar.bz2
gentoo-d459cd74b963c1865c26b90cefe7701f4b72c5bb.zip
app-arch/libdeflate: enable gzip & zlib unconditionally
Closes: https://bugs.gentoo.org/937883 Signed-off-by: Paul Zander <negril.nx+gentoo@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-arch/libdeflate')
-rw-r--r--app-arch/libdeflate/libdeflate-1.19-r1.ebuild (renamed from app-arch/libdeflate/libdeflate-1.19.ebuild)12
-rw-r--r--app-arch/libdeflate/libdeflate-1.20-r1.ebuild (renamed from app-arch/libdeflate/libdeflate-1.20.ebuild)12
-rw-r--r--app-arch/libdeflate/libdeflate-9999.ebuild12
-rw-r--r--app-arch/libdeflate/metadata.xml6
4 files changed, 14 insertions, 28 deletions
diff --git a/app-arch/libdeflate/libdeflate-1.19.ebuild b/app-arch/libdeflate/libdeflate-1.19-r1.ebuild
index b637d83a6dfe..322c508072c7 100644
--- a/app-arch/libdeflate/libdeflate-1.19.ebuild
+++ b/app-arch/libdeflate/libdeflate-1.19-r1.ebuild
@@ -20,16 +20,12 @@ LICENSE="MIT"
SLOT="0"
# the zlib USE-flag enables support for zlib
# the test USE-flag programs depend on sys-libs/zlib for comparison tests
-IUSE="+gzip +utils +zlib test"
+IUSE="+utils test"
RESTRICT="
!test? ( test )
"
-REQUIRED_USE="
- utils? ( gzip )
-"
-
DEPEND="
test? ( sys-libs/zlib )
"
@@ -47,10 +43,10 @@ src_configure() {
-DLIBDEFLATE_COMPRESSION_SUPPORT="yes"
-DLIBDEFLATE_DECOMPRESSION_SUPPORT="yes"
- -DLIBDEFLATE_BUILD_GZIP="$(usex gzip "$(usex utils)" )"
- -DLIBDEFLATE_GZIP_SUPPORT="$(usex gzip)"
+ -DLIBDEFLATE_BUILD_GZIP="$(usex utils)"
+ -DLIBDEFLATE_GZIP_SUPPORT="yes"
- -DLIBDEFLATE_ZLIB_SUPPORT="$(usex zlib)"
+ -DLIBDEFLATE_ZLIB_SUPPORT="yes"
-DLIBDEFLATE_BUILD_TESTS="$(usex test)"
)
diff --git a/app-arch/libdeflate/libdeflate-1.20.ebuild b/app-arch/libdeflate/libdeflate-1.20-r1.ebuild
index 395b2234ceea..12a547db272d 100644
--- a/app-arch/libdeflate/libdeflate-1.20.ebuild
+++ b/app-arch/libdeflate/libdeflate-1.20-r1.ebuild
@@ -20,16 +20,12 @@ LICENSE="MIT"
SLOT="0"
# the zlib USE-flag enables support for zlib
# the test USE-flag programs depend on sys-libs/zlib for comparison tests
-IUSE="+gzip +utils +zlib test"
+IUSE="+utils test"
RESTRICT="
!test? ( test )
"
-REQUIRED_USE="
- utils? ( gzip )
-"
-
DEPEND="
test? ( sys-libs/zlib[${MULTILIB_USEDEP}] )
"
@@ -47,10 +43,10 @@ src_configure() {
-DLIBDEFLATE_COMPRESSION_SUPPORT="yes"
-DLIBDEFLATE_DECOMPRESSION_SUPPORT="yes"
- -DLIBDEFLATE_BUILD_GZIP="$(usex gzip "$(usex utils)" )"
- -DLIBDEFLATE_GZIP_SUPPORT="$(usex gzip)"
+ -DLIBDEFLATE_BUILD_GZIP="$(usex utils)"
+ -DLIBDEFLATE_GZIP_SUPPORT="yes"
- -DLIBDEFLATE_ZLIB_SUPPORT="$(usex zlib)"
+ -DLIBDEFLATE_ZLIB_SUPPORT="yes"
-DLIBDEFLATE_BUILD_TESTS="$(usex test)"
)
diff --git a/app-arch/libdeflate/libdeflate-9999.ebuild b/app-arch/libdeflate/libdeflate-9999.ebuild
index 395b2234ceea..12a547db272d 100644
--- a/app-arch/libdeflate/libdeflate-9999.ebuild
+++ b/app-arch/libdeflate/libdeflate-9999.ebuild
@@ -20,16 +20,12 @@ LICENSE="MIT"
SLOT="0"
# the zlib USE-flag enables support for zlib
# the test USE-flag programs depend on sys-libs/zlib for comparison tests
-IUSE="+gzip +utils +zlib test"
+IUSE="+utils test"
RESTRICT="
!test? ( test )
"
-REQUIRED_USE="
- utils? ( gzip )
-"
-
DEPEND="
test? ( sys-libs/zlib[${MULTILIB_USEDEP}] )
"
@@ -47,10 +43,10 @@ src_configure() {
-DLIBDEFLATE_COMPRESSION_SUPPORT="yes"
-DLIBDEFLATE_DECOMPRESSION_SUPPORT="yes"
- -DLIBDEFLATE_BUILD_GZIP="$(usex gzip "$(usex utils)" )"
- -DLIBDEFLATE_GZIP_SUPPORT="$(usex gzip)"
+ -DLIBDEFLATE_BUILD_GZIP="$(usex utils)"
+ -DLIBDEFLATE_GZIP_SUPPORT="yes"
- -DLIBDEFLATE_ZLIB_SUPPORT="$(usex zlib)"
+ -DLIBDEFLATE_ZLIB_SUPPORT="yes"
-DLIBDEFLATE_BUILD_TESTS="$(usex test)"
)
diff --git a/app-arch/libdeflate/metadata.xml b/app-arch/libdeflate/metadata.xml
index 17956aa98f85..a55b0a6392fb 100644
--- a/app-arch/libdeflate/metadata.xml
+++ b/app-arch/libdeflate/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<!-- maintainer-wanted -->
- <maintainer type="person" proxied="yes">
+ <maintainer type="person" proxied="yes">
<email>negril.nx+gentoo@gmail.com</email>
<name>Paul Zander</name>
</maintainer>
@@ -11,10 +11,8 @@
<name>Proxy Maintainers</name>
</maintainer>
<use>
- <flag name="gzip">Support the gzip format</flag>
<flag name="test">Build the test programs (requires <pkg>sys-libs/zlib</pkg>)</flag>
<flag name="utils">Build the libdeflate-gzip program</flag>
- <flag name="zlib">Support the zlib format</flag>
</use>
<upstream>
<remote-id type="github">ebiggers/libdeflate</remote-id>