summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-03 03:28:36 +0000
committerSam James <sam@gentoo.org>2023-01-03 03:33:42 +0000
commite82c66c6494159d59fe2d771f8eec43748dd869b (patch)
treed1f51ce7a347d1b75fe9f316be89f09d41018c95 /app-arch/cpio
parentsys-devel/clang-runtime: keyword 16.0.0_pre20230101 for ~loong (diff)
downloadgentoo-e82c66c6494159d59fe2d771f8eec43748dd869b.tar.gz
gentoo-e82c66c6494159d59fe2d771f8eec43748dd869b.tar.bz2
gentoo-e82c66c6494159d59fe2d771f8eec43748dd869b.zip
app-arch/cpio: fix build w/ clang 16
Closes: https://bugs.gentoo.org/880373 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-arch/cpio')
-rw-r--r--app-arch/cpio/cpio-2.13-r5.ebuild (renamed from app-arch/cpio/cpio-2.13-r4.ebuild)3
-rw-r--r--app-arch/cpio/files/cpio-2.13-wincompatible-function-pointer-types.patch23
2 files changed, 25 insertions, 1 deletions
diff --git a/app-arch/cpio/cpio-2.13-r4.ebuild b/app-arch/cpio/cpio-2.13-r5.ebuild
index 79d4ada19621..b184309b5c44 100644
--- a/app-arch/cpio/cpio-2.13-r4.ebuild
+++ b/app-arch/cpio/cpio-2.13-r5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -24,6 +24,7 @@ PATCHES=(
"${WORKDIR}"/${P}-CVE-2021-38185.patch
"${FILESDIR}"/${PN}-2.13-sysmacros-glibc-2.26.patch
"${FILESDIR}"/${PN}-2.13-fix-no-absolute-filenames-revert-CVE-2015-1197-handling.patch
+ "${FILESDIR}"/${PN}-2.13-wincompatible-function-pointer-types.patch
)
src_prepare() {
diff --git a/app-arch/cpio/files/cpio-2.13-wincompatible-function-pointer-types.patch b/app-arch/cpio/files/cpio-2.13-wincompatible-function-pointer-types.patch
new file mode 100644
index 000000000000..4f2dc3153656
--- /dev/null
+++ b/app-arch/cpio/files/cpio-2.13-wincompatible-function-pointer-types.patch
@@ -0,0 +1,23 @@
+https://bugs.gentoo.org/880373
+https://savannah.gnu.org/bugs/index.php?63349
+https://git.savannah.gnu.org/cgit/gnulib.git/commit/?id=0cc39712803ade7b2d4b89c36b143dad72404063
+
+From 0cc39712803ade7b2d4b89c36b143dad72404063 Mon Sep 17 00:00:00 2001
+From: Bruno Haible <bruno@clisp.org>
+Date: Sun, 18 Oct 2020 14:37:13 +0200
+Subject: obstack: Fix a clang warning.
+
+* lib/obstack.c (print_and_abort): Mark as __attribute_noreturn__.
+--- a/gnu/obstack.c
++++ b/gnu/obstack.c
+@@ -326,7 +326,7 @@ int obstack_exit_failure = EXIT_FAILURE;
+ # include <libio/iolibio.h>
+ # endif
+
+-static _Noreturn void
++static __attribute_noreturn__ void
+ print_and_abort (void)
+ {
+ /* Don't change any of these strings. Yes, it would be possible to add
+--
+cgit v1.1