summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-18 17:51:00 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-18 18:59:06 +0200
commit380af30eb3d4ea67ac716d453bdc282ad766d578 (patch)
treeb4899f2ac5209218993cff300d0d47162ab7388d /app-arch/brotli/brotli-9999.ebuild
parentsci-libs/vtk: unrestrict hdf5 (diff)
downloadgentoo-380af30eb3d4ea67ac716d453bdc282ad766d578.tar.gz
gentoo-380af30eb3d4ea67ac716d453bdc282ad766d578.tar.bz2
gentoo-380af30eb3d4ea67ac716d453bdc282ad766d578.zip
app-arch/brotli: Fix tests, PEP517, py3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-arch/brotli/brotli-9999.ebuild')
-rw-r--r--app-arch/brotli/brotli-9999.ebuild40
1 files changed, 25 insertions, 15 deletions
diff --git a/app-arch/brotli/brotli-9999.ebuild b/app-arch/brotli/brotli-9999.ebuild
index 68bd7f1fb826..f206ce927497 100644
--- a/app-arch/brotli/brotli-9999.ebuild
+++ b/app-arch/brotli/brotli-9999.ebuild
@@ -4,7 +4,9 @@
EAPI=8
DISTUTILS_OPTIONAL="1"
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
inherit cmake-multilib distutils-r1
if [[ ${PV} == *9999* ]] ; then
@@ -12,24 +14,34 @@ if [[ ${PV} == *9999* ]] ; then
inherit git-r3
else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
- SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="
+ https://github.com/google/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+ test? (
+ https://dev.gentoo.org/~mgorny/dist/${P}.testdata.tar.xz
+ )
+ "
fi
DESCRIPTION="Generic-purpose lossless compression algorithm"
-HOMEPAGE="https://github.com/google/brotli"
+HOMEPAGE="https://github.com/google/brotli/"
LICENSE="MIT python? ( Apache-2.0 )"
SLOT="0/$(ver_cut 1)"
IUSE="python static-libs test"
-
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
RESTRICT="!test? ( test )"
+RDEPEND="
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="
+ ${RDEPEND}
+"
+
DOCS=( README.md CONTRIBUTING.md )
-RDEPEND="python? ( ${PYTHON_DEPS} )"
-DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/${PV}-linker.patch" )
src_prepare() {
cmake_src_prepare
@@ -42,26 +54,21 @@ multilib_src_configure() {
)
cmake_src_configure
}
+
src_configure() {
cmake-multilib_src_configure
use python && distutils-r1_src_configure
}
-multilib_src_compile() {
- cmake_src_compile
-}
src_compile() {
cmake-multilib_src_compile
use python && distutils-r1_src_compile
}
python_test() {
- esetup.py test || die
+ eunittest -s python -p "*_test.py"
}
-multilib_src_test() {
- cmake_src_test
-}
src_test() {
cmake-multilib_src_test
use python && distutils-r1_src_test
@@ -69,8 +76,11 @@ src_test() {
multilib_src_install() {
cmake_src_install
- use static-libs || rm "${ED}"/usr/$(get_libdir)/*.a || die
+ if ! use static-libs; then
+ rm "${ED}"/usr/$(get_libdir)/*.a || die
+ fi
}
+
multilib_src_install_all() {
use python && distutils-r1_src_install
}