summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2024-03-06 07:53:20 +0200
committerViorel Munteanu <ceamac@gentoo.org>2024-03-06 07:58:26 +0200
commite0a36e389d8037f1a42fcf08bbba9471ab132aff (patch)
tree649051e8fcee0c6499db0d8527604bbff8334704 /app-admin
parentmedia-libs/libpgf: fix build on musl (diff)
downloadgentoo-e0a36e389d8037f1a42fcf08bbba9471ab132aff.tar.gz
gentoo-e0a36e389d8037f1a42fcf08bbba9471ab132aff.tar.bz2
gentoo-e0a36e389d8037f1a42fcf08bbba9471ab132aff.zip
app-admin/linode-cli: add 5.48.3
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/linode-cli/Manifest1
-rw-r--r--app-admin/linode-cli/linode-cli-5.48.3.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/app-admin/linode-cli/Manifest b/app-admin/linode-cli/Manifest
index f5c159c9d423..64dfa3320a84 100644
--- a/app-admin/linode-cli/Manifest
+++ b/app-admin/linode-cli/Manifest
@@ -1,2 +1,3 @@
DIST linode-cli-5.47.1.tar.gz 128364 BLAKE2B db21cdd9a1bfbe17fb17b8b0e27ca36bb15c7d3b16ddde4dcc59a9ce64cd34d644d3d5d120efb88bb146767cf9b2c3ee820a847a2fcff487a11bc3abd6973870 SHA512 b61ac1e7c97a1395b150227fe822bc2e7199ed15a44c6d93d71bfdbc2f919827e87e89cf41a47b069be06144a849f5ab11c9dd7f38d138f80ce80563f55bf75a
DIST linode-cli-5.48.2.tar.gz 141600 BLAKE2B fadabfb421945809ceba396324ac9930d1fd795bceab4e90023038881fb8ba5af1b19187f414e70b5a86ea7d560202c76669dfe76ba952bcbe958b7213aff241 SHA512 f2d0e3f62ff93fc9906d70b1121e73f98319dd8afc38ddb124d35295dffef085aa75c93d299538499ea71d087de19060fc3f52ab5f6b31ef47f46435f010b0fd
+DIST linode-cli-5.48.3.tar.gz 142927 BLAKE2B 48ae197d780f77a7a4dbf54d4e9959d28c117d90e052f401f563f1557dc11155afc5d16da1140e9ed2828fa3e19243e91205759636247d2fb893383975d89f43 SHA512 9efd3f0392848ebcd896becff191e94c90cbec01cc2b805c0262ecb3c40c51346d0b42891ddaadb9191d75e379083f68e4c9aa35f9ba7c6309c74ae3febbde7a
diff --git a/app-admin/linode-cli/linode-cli-5.48.3.ebuild b/app-admin/linode-cli/linode-cli-5.48.3.ebuild
new file mode 100644
index 000000000000..2ce8851657d3
--- /dev/null
+++ b/app-admin/linode-cli/linode-cli-5.48.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+inherit distutils-r1 pypi
+
+DESCRIPTION="Linode Command Line Interface"
+HOMEPAGE="https://github.com/linode/linode-cli https://www.linode.com/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# Tests require network, a linode account and an API key.
+# WARNING: tests will incur costs and will wipe the account.
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/linode-metadata[${PYTHON_USEDEP}]
+ dev-python/openapi3[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ <dev-python/urllib3-3[${PYTHON_USEDEP}]
+"