summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-19 18:37:38 +0000
committerSam James <sam@gentoo.org>2023-02-19 18:37:47 +0000
commitc5bc82ad10a33da634522bae36d22966485ffbb3 (patch)
treec3ad558a6cd265674f8bc55f2b03cf69a8c9e3f3 /app-admin
parentdev-libs/starpu: drop openmp refs in old (diff)
downloadgentoo-c5bc82ad10a33da634522bae36d22966485ffbb3.tar.gz
gentoo-c5bc82ad10a33da634522bae36d22966485ffbb3.tar.bz2
gentoo-c5bc82ad10a33da634522bae36d22966485ffbb3.zip
app-admin/rasdaemon: add 0.8.0
Closes: https://bugs.gentoo.org/890286 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/rasdaemon/Manifest1
-rw-r--r--app-admin/rasdaemon/files/rasdaemon-0.8.0-bashisms-configure.patch40
-rw-r--r--app-admin/rasdaemon/rasdaemon-0.8.0.ebuild83
3 files changed, 124 insertions, 0 deletions
diff --git a/app-admin/rasdaemon/Manifest b/app-admin/rasdaemon/Manifest
index 4a209b8bbcc0..4ce4630f3ac4 100644
--- a/app-admin/rasdaemon/Manifest
+++ b/app-admin/rasdaemon/Manifest
@@ -1,2 +1,3 @@
DIST rasdaemon-0.6.8.tar.gz 161343 BLAKE2B 95dab212e404480d45e5b07fa0f9ec7361036c9295a81dd082657c71cf8ad1114cc28f163b8975733e2042dfeb957f8da71dc52440249c75c24653c1ce235e86 SHA512 634638154c6b0bf7a079d6aba884a55e540c9edc3c25715a792ad7535c68629618e9cef8b6ec7e20845f78bd57f712d437be4d772523020f09d30cce42759a30
DIST rasdaemon-0.7.0.tar.bz2 433555 BLAKE2B cf73f59558d8a6f3138fea20e7096a1b1214dd44a4518da88a4b1f0c4c92a6df4eb7922e9a2e76d5012364219067cf66e220d8f54588ab22acf09937e41aa2dc SHA512 a7938ccd8171d849b5d89df6ab90942278c824a3dbd17abda8ae3d80ce5227cbc3fe23b31806609114482606d780ec7f0676a0fedfa950ed8cb5a59f3583bd57
+DIST rasdaemon-0.8.0.tar.bz2 394983 BLAKE2B 24209f468fea2bc4e85dcac51e363e44a8a44b224b448ec1330bcd15a5b2b4b3cceeec78dbc86b4a88f5a378ecacba62cdba8e9c3e2b1b3a70be85a18af166ab SHA512 f6262f098fd2a08d35fef2c25e2452a202151d4cc93a1829e821abd564acf7dcf80b08f819cbd7f04244dcc9f1dec5d9138aa013bb43c8fcf19d340233275614
diff --git a/app-admin/rasdaemon/files/rasdaemon-0.8.0-bashisms-configure.patch b/app-admin/rasdaemon/files/rasdaemon-0.8.0-bashisms-configure.patch
new file mode 100644
index 000000000000..e227df6724b2
--- /dev/null
+++ b/app-admin/rasdaemon/files/rasdaemon-0.8.0-bashisms-configure.patch
@@ -0,0 +1,40 @@
+https://github.com/mchehab/rasdaemon/pull/89
+
+From 9461d22e334686f76c99477386072f4673cd0a72 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sun, 19 Feb 2023 18:33:20 +0000
+Subject: [PATCH] configure.ac: fix bashisms
+
+configure scripts need to be runnable with a POSIX-compliant /bin/sh.
+
+On many (but not all!) systems, /bin/sh is provided by Bash, so errors
+like this aren't spotted. Notably Debian defaults to /bin/sh provided
+by dash which doesn't tolerate such bashisms as '=='.
+
+This retains compatibility with bash.
+
+Fixes configure warnings/errors like:
+```
+checking for libtraceevent... yes
+./configure: 13430: test: x: unexpected operator
+./configure: 13439: test: x: unexpected operator
+```
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/configure.ac
++++ b/configure.ac
+@@ -170,11 +170,11 @@ AM_COND_IF([WITH_AMP_NS_DECODE], [USE_AMP_NS_DECODE="yes"], [USE_AMP_NS_DECODE="
+ AC_ARG_ENABLE([cpu_fault_isolation],
+ AS_HELP_STRING([--enable-cpu-fault-isolation], [enable cpu online fault isolation]))
+
+-AS_IF([test "x$enable_cpu_fault_isolation" = "xyes" || test "x$enable_all" == "xyes"], [
++AS_IF([test "x$enable_cpu_fault_isolation" = "xyes" || test "x$enable_all" = "xyes"], [
+ AC_DEFINE(HAVE_CPU_FAULT_ISOLATION,1,"have cpu online fault isolation")
+ AC_SUBST([WITH_CPU_FAULT_ISOLATION])
+ ])
+-AM_CONDITIONAL([WITH_CPU_FAULT_ISOLATION], [test x$enable_cpu_fault_isolation = xyes || test x$enable_all == xyes])
++AM_CONDITIONAL([WITH_CPU_FAULT_ISOLATION], [test x$enable_cpu_fault_isolation = xyes || test x$enable_all = xyes])
+ AM_COND_IF([WITH_CPU_FAULT_ISOLATION], [USE_CPU_FAULT_ISOLATION="yes"], [USE_CPU_FAULT_ISOLATION="no"])
+
+ test "$sysconfdir" = '${prefix}/etc' && sysconfdir=/etc
+
diff --git a/app-admin/rasdaemon/rasdaemon-0.8.0.ebuild b/app-admin/rasdaemon/rasdaemon-0.8.0.ebuild
new file mode 100644
index 000000000000..6d4033b70e55
--- /dev/null
+++ b/app-admin/rasdaemon/rasdaemon-0.8.0.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic linux-info systemd
+
+DESCRIPTION="Reliability, Availability and Serviceability logging tool"
+HOMEPAGE="https://github.com/mchehab/rasdaemon"
+# This if can be dropped > 0.8.0, see https://github.com/mchehab/rasdaemon/issues/88
+if [[ ${PV} == 0.8.0 ]] ; then
+ SRC_URI="https://github.com/mchehab/rasdaemon/releases/download/refs%2Fheads%2Fmaster/${P}.tar.bz2"
+else
+ SRC_URI="https://github.com/mchehab/rasdaemon/releases/download/v${PV}/${P}.tar.bz2"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="
+ dev-db/sqlite
+ dev-libs/libtraceevent
+ elibc_musl? ( sys-libs/argp-standalone )
+"
+RDEPEND="
+ ${DEPEND}
+ dev-perl/DBI
+ dev-perl/DBD-SQLite
+ sys-apps/dmidecode
+"
+BDEPEND="sys-devel/gettext"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.0-bashisms-configure.patch
+)
+
+pkg_setup() {
+ linux-info_pkg_setup
+ local CONFIG_CHECK="~ACPI_EXTLOG ~DEBUG_FS"
+ check_extra_config
+}
+
+src_prepare() {
+ default
+
+ # Only here for 0.8.0's bashism patch
+ eautoreconf
+}
+
+src_configure() {
+ local myconfargs=(
+ --enable-sqlite3
+ --enable-abrt-report
+ --enable-aer
+ --enable-arm
+ --enable-extlog
+ --enable-hisi-ns-decode
+ --enable-mce
+ --enable-non-standard
+ --enable-devlink
+ --enable-diskerror
+ --enable-memory-ce-pfa
+ --includedir="/usr/include/${PN}"
+ --localstatedir=/var
+ )
+
+ use elibc_musl && append-libs -largp
+
+ econf "${myconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ keepdir "/var/lib/${PN}"
+
+ systemd_dounit misc/*.service
+
+ newinitd "${FILESDIR}/rasdaemon.openrc-r2" rasdaemon
+ newinitd "${FILESDIR}/ras-mc-ctl.openrc-r1" ras-mc-ctl
+ newconfd "${FILESDIR}"/rasdaemon.confd rasdaemon
+}