summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2018-06-25 09:16:37 -0400
committerCraig Andrews <candrews@gentoo.org>2018-06-25 09:16:58 -0400
commit6e7d09d44473d25f519a968f83efdc008ea9822f (patch)
tree90c1f106169f9e5e6b94cbd194f73276cb5014f0 /app-admin
parentx11-libs/pango: Stable for HPPA too. (diff)
downloadgentoo-6e7d09d44473d25f519a968f83efdc008ea9822f.tar.gz
gentoo-6e7d09d44473d25f519a968f83efdc008ea9822f.tar.bz2
gentoo-6e7d09d44473d25f519a968f83efdc008ea9822f.zip
app-admin/needrestart: 3.3 version bump
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/needrestart/Manifest1
-rw-r--r--app-admin/needrestart/needrestart-3.3.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/app-admin/needrestart/Manifest b/app-admin/needrestart/Manifest
index 4984f6ceee40..7e8f6d796cc3 100644
--- a/app-admin/needrestart/Manifest
+++ b/app-admin/needrestart/Manifest
@@ -2,3 +2,4 @@ DIST needrestart-2.11.tar.gz 52156 BLAKE2B fb3ffbf6f7876625ad0b7db4feb629c80f079
DIST needrestart-3.0.tar.gz 58437 BLAKE2B 6f3b79f793dab85af2a68f3796926b958c077b16c357969943db867dead470cef20aadb076a12a0e3161efc64c82cd1df7f6cdbc70f73cce563a11dec472f69a SHA512 6b653e29b10e497563e67102e11833f7c97d2bde697a99130ff89d5fcd2e616fec279328656f44ccdbb62a2c533bf10827b035efad7785ef5d0556c7f37e625f
DIST needrestart-3.1.tar.gz 58882 BLAKE2B c29d7a56905b047f73743075f520116004a8eed8d88ca402e958fc6a4a430213c9ba4dec469dd1221cbad5b8c6123a9e1acb451f63c6dfdfcd11dc27bce147af SHA512 a55f4e83be676d26d815f28df2a7d56c17bd74d6c1a801f5d1ee05344853d7272dda018b3c19b7753dd6f256e793261d5581df49449c4c9577309add15d4bb70
DIST needrestart-3.2.tar.gz 59702 BLAKE2B 9eb8073a4dc6f7a402ee9ce055960663a08d3d4b11805ef4189c8416d59bda53e02f4b07f43f49b73a99eb9b82d8e94ca5757cd6c7463dcfa34949ca7e6521da SHA512 56e881d73b1bf1cbee8a94ae871c2fe350d6b31e4701fdc256bbedb0d9934111f5f201d3d7b7f25ff54f78fd450c95f4c2bad6f06de5e9ce379a393fd73280d5
+DIST needrestart-3.3.tar.gz 59814 BLAKE2B bfba00dee7c0f225efcaaa80b301eb38d0ea82645f253c8bef9294102f9f4183433ed1b6efe71a9dc34c65f76364ff3fc2344e840b34f97361f3ddcd0dc9ab4b SHA512 ea2f3cbe228a6b879905bd3b3de8b5e0bb2362e8d3cd566817d2e7d519d54207ff5923eb8e49cbd8ffe8ed50729f4da04bf4d55268e806f49157860584058d50
diff --git a/app-admin/needrestart/needrestart-3.3.ebuild b/app-admin/needrestart/needrestart-3.3.ebuild
new file mode 100644
index 000000000000..062247caf71e
--- /dev/null
+++ b/app-admin/needrestart/needrestart-3.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/liske/${PN}.git"
+ inherit git-r3
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/liske/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Restart daemons after library updates"
+HOMEPAGE="https://fiasko-nw.net/~thomas/tag/needrestart.html https://github.com/liske/needrestart"
+
+SLOT="0"
+LICENSE="GPL-2+"
+
+RDEPEND="
+ >=sys-apps/sed-4.2.2
+ dev-lang/perl:=
+ dev-perl/libintl-perl
+ dev-perl/Module-Find
+ dev-perl/Module-ScanDeps
+ dev-perl/Proc-ProcessTable
+ dev-perl/Sort-Naturally
+ dev-perl/TermReadKey
+ sys-apps/init-system-helpers
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+"
+
+src_install() {
+ default
+ doman man/*.1
+ dodoc -r ex
+}