summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-15 05:51:56 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-15 06:36:58 +0100
commit66e8982792284ff2058eb5236377c8a8b0e120e0 (patch)
tree4524be4e5ae99100808ba753a3dfd6ebbe28c615 /app-admin
parentdev-python/boto3: Bump to 1.29.0 (diff)
downloadgentoo-66e8982792284ff2058eb5236377c8a8b0e120e0.tar.gz
gentoo-66e8982792284ff2058eb5236377c8a8b0e120e0.tar.bz2
gentoo-66e8982792284ff2058eb5236377c8a8b0e120e0.zip
app-admin/awscli: Bump to 1.30.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.30.0.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 7b39cc3d6bd8..0206c0bab030 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -1,3 +1,4 @@
DIST aws-cli-1.29.78.gh.tar.gz 2573503 BLAKE2B 6782a7774568adf5296461e19d71b9de992d9301e3d9c50b97c641448ea0fb9e161feb80cdbce50291fce7d37eaabbc92740ca6b26f432cc5b9105233c2949f8 SHA512 455e6cacb935c1075d9730dda3147dc17598ca01ff9224b9a5f0dffa003a10fb3f2f2e17db1aea9e44b353a5fdd1e3b692308b895ba79ef6433804156ba54b1d
DIST aws-cli-1.29.84.gh.tar.gz 2576584 BLAKE2B c442a433b0deaacb8b0a94ecb4ce296b60eb6f364bf5626d4ccf606d35b8ad22a2859c29486c9eaa8091edc9f796d271b5b7308638d10f72f128b4548f5250bf SHA512 6f46bde5016df5d227861ed80e847a893144f290dba11c57966f6ccf043690fad42dcc11d18e1b2d27225c8b070063a2c20b8a622628bde37887e44d0e0e7fb5
DIST aws-cli-1.29.85.gh.tar.gz 2577082 BLAKE2B 8d16b3a989b6a12a154baa8b5d25be6c35c6201f6041cc9f100274815f746c55b1107274575dee928250743b72f02d3db17c8198a9fd3bff7c3bcd827def5cdb SHA512 88164eeddc9d99811d20aa7cd607720fafaa8324738db3eb0aaa76cdb2e8710b828f64c0da3fb14409130fb41880c724918617742a1a3e8d92200f9707865db8
+DIST aws-cli-1.30.0.gh.tar.gz 2584557 BLAKE2B d88e0987b019ca6a86ffb599ee894b8270dda4c4cae2a4bf0a74438d821533d5875d379132f76c70e93bc8b3136f3a8374b60d797f064921597b259589bd5bfe SHA512 5fd1ee8e4f978cfc4964799b3556eae8c0a7cec367dd4f0c096971a948d1ce7b8bc008b05e84c67723f0d603470777d075cc12a014cb2466789033de62e9078e
diff --git a/app-admin/awscli/awscli-1.30.0.ebuild b/app-admin/awscli/awscli-1.30.0.ebuild
new file mode 100644
index 000000000000..e5b1ee0667a3
--- /dev/null
+++ b/app-admin/awscli/awscli-1.30.0.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.7.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=( "${serial_tests[@]}" )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}