summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-12-06 09:57:02 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2019-12-06 10:10:15 -0600
commit226d103a5c90dc82468288f7d45b94765a756473 (patch)
treefbbb98d06c824b60a42412fc2f6ee6290baceff8 /app-admin
parentacct-group/tor: new group package for UID 43 (diff)
downloadgentoo-226d103a5c90dc82468288f7d45b94765a756473.tar.gz
gentoo-226d103a5c90dc82468288f7d45b94765a756473.tar.bz2
gentoo-226d103a5c90dc82468288f7d45b94765a756473.zip
app-admin/ansible: 2.9.2 bump
Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/ansible/Manifest1
-rw-r--r--app-admin/ansible/ansible-2.9.2.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/app-admin/ansible/Manifest b/app-admin/ansible/Manifest
index 11aa3647d28b..a1016ebd0201 100644
--- a/app-admin/ansible/Manifest
+++ b/app-admin/ansible/Manifest
@@ -4,3 +4,4 @@ DIST ansible-2.8.6.tar.gz 12689211 BLAKE2B 9c451037f705f2e591633b59700e89c6de672
DIST ansible-2.8.7.tar.gz 12697144 BLAKE2B f88225b358ff9fad352c04a053100c5aa612f54ba7ad8e3a700d61e030fd0b5850055b83861d3ad76e614d3e786a2ed719f63b7f452ce24d7e27d79d386b8eed SHA512 166009780c8bb5b35beb9604412d4e5e3874e13b04f3ce694d726dc5bfb064f73a17ec3c814c8a67e28d57e7c327276b6cb66a9a0dba7138d702427ec13b4de3
DIST ansible-2.9.0.tar.gz 14126941 BLAKE2B 409f94af0fa8483934b957cf31f3a762e575203f4f809c44cbf5c74cc945deb065f97374b93dd2aa03a8002b17d7da0bfad3ea80c11673b02be3d0179c34b7c9 SHA512 47e0738bbf9918254d7b33ddc0a8f89a101995ccc3cb846be9ff10bdbc7687fb8a5390d8b976b3ce17fa1325ab63a592161b026d5d943a01f8a5803fca67312a
DIST ansible-2.9.1.tar.gz 14144123 BLAKE2B 20b288aed59221c63cbc345d6f1bb33770b864229ddfdcb3e3d7c5ddde0978b05f1139466945a92145772f1d659a43d406c7486df91f7f16135f66b7282761ab SHA512 fdb25017b96475a6c182bba2f32050f0eaa6f22d17f166b98ce0f0cb40fd12dbbc5ede9912624fa4c5d4a8de472b28c2eb2b569700537c7d4b4c568d7e38f21b
+DIST ansible-2.9.2.tar.gz 14157188 BLAKE2B 4c1207bd43f7797d8d9cb1d4612e866eebbf8c19ee060cf1eb7daa68415be5d7718c79d756454648e66a13434eacba6a07c8de31c4ec4b12e0474563d8844e46 SHA512 522dd84af9493ceafd95ff0fc806a671f3d1f10d0ca074ef41875eb966d39e64b834e0b98a35d81d9d9d96efef8069db604c8080ce8cbb1ce2e8b13bf5c30a6a
diff --git a/app-admin/ansible/ansible-2.9.2.ebuild b/app-admin/ansible/ansible-2.9.2.ebuild
new file mode 100644
index 000000000000..29be3eba4da6
--- /dev/null
+++ b/app-admin/ansible/ansible-2.9.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://ansible.com/"
+SRC_URI="https://releases.ansible.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~x64-macos"
+IUSE="doc test"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ net-misc/sshpass
+ virtual/ssh
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-notfound-page[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+python_compile_all() {
+ if use doc; then
+ cd docs/docsite || die
+ export CPUS=4
+ emake -f Makefile.sphinx html
+ fi
+}
+
+python_test() {
+ nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/docsite/_build/html/. )
+ distutils-r1_python_install_all
+
+ dodoc -r examples
+}