summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/xstow/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/xstow/files')
-rw-r--r--app-admin/xstow/files/99xstow3
-rw-r--r--app-admin/xstow/files/xstow-0.5.1-gcc43.patch67
-rw-r--r--app-admin/xstow/files/xstow-1.0.1-ncurses.patch56
3 files changed, 126 insertions, 0 deletions
diff --git a/app-admin/xstow/files/99xstow b/app-admin/xstow/files/99xstow
new file mode 100644
index 000000000000..07625f392537
--- /dev/null
+++ b/app-admin/xstow/files/99xstow
@@ -0,0 +1,3 @@
+LDPATH=/var/lib/lib
+PATH=/var/lib/bin
+MANPATH=/var/lib/share/man
diff --git a/app-admin/xstow/files/xstow-0.5.1-gcc43.patch b/app-admin/xstow/files/xstow-0.5.1-gcc43.patch
new file mode 100644
index 000000000000..ded9e32cc577
--- /dev/null
+++ b/app-admin/xstow/files/xstow-0.5.1-gcc43.patch
@@ -0,0 +1,67 @@
+--- xstow-0.5.1.orig/src/format.h
++++ xstow-0.5.1/src/format.h
+@@ -648,17 +648,17 @@
+
+ switch( num_of_args )
+ {
+- case 1: n = std::snprintf( buffer, buffer_size, format.c_str(),
++ case 1: n = snprintf( buffer, buffer_size, format.c_str(),
+ D( a ) ); break;
+- case 2: n = std::snprintf( buffer, buffer_size, format.c_str(),
++ case 2: n = snprintf( buffer, buffer_size, format.c_str(),
+ D( a ), D( b ) ); break;
+- case 3: n = std::snprintf( buffer, buffer_size, format.c_str(),
++ case 3: n = snprintf( buffer, buffer_size, format.c_str(),
+ D( a ), D( b ), D( c ) ); break;
+- case 4: n = std::snprintf( buffer, buffer_size, format.c_str(),
++ case 4: n = snprintf( buffer, buffer_size, format.c_str(),
+ D( a ), D( b ), D( c ), D( d ) ); break;
+- case 5: n = std::snprintf( buffer, buffer_size, format.c_str(),
++ case 5: n = snprintf( buffer, buffer_size, format.c_str(),
+ D( a ), D( b ), D( c ), D( d ), D( e ) ); break;
+- case 6: n = std::snprintf( buffer, buffer_size, format.c_str(),
++ case 6: n = snprintf( buffer, buffer_size, format.c_str(),
+ D( a ), D( b ), D( c ), D( d ), D( e ), D( f ) ); break;
+ }
+
+--- xstow-0.5.1.orig/src/main.cpp
++++ xstow-0.5.1/src/main.cpp
+@@ -1,3 +1,4 @@
++#include <cstdlib>
+ #include <iostream>
+
+ #include "local_config.h"
+--- xstow-0.5.1.orig/src/cppdir.cpp
++++ xstow-0.5.1/src/cppdir.cpp
+@@ -1,6 +1,8 @@
+ #include "cppdir.h"
+ #include "debug.h"
+
++#include <cstdlib>
++
+ #define OUT(level) DEBUG_OUT( level, MODULE_CPPDIR)
+
+ extern "C" {
+--- xstow-0.5.1.orig/src/setup.cpp
++++ xstow-0.5.1/src/setup.cpp
+@@ -5,6 +5,8 @@
+ #include "debug.h"
+ #include "nignore.h"
+
++#include <cstdlib>
++
+ #undef OUT
+
+ #define OUT( level ) DEBUG_OUT( level, MODULE_SETUP )
+--- xstow-0.5.1.orig/src/tree.cpp
++++ xstow-0.5.1/src/tree.cpp
+@@ -26,6 +26,7 @@
+
+
+ #include <algorithm>
++#include <cstring>
+
+ #define OUT(level) DEBUG_OUT(level, MODULE_TREE)
+
+
+
diff --git a/app-admin/xstow/files/xstow-1.0.1-ncurses.patch b/app-admin/xstow/files/xstow-1.0.1-ncurses.patch
new file mode 100644
index 000000000000..b7d29f287e7f
--- /dev/null
+++ b/app-admin/xstow/files/xstow-1.0.1-ncurses.patch
@@ -0,0 +1,56 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -91,11 +91,12 @@
+ AC_MSG_RESULT(disabled)
+ support_curses=0
+ else
++ AC_MSG_RESULT(enabled)
+ support_curses=1
+ fi
+ ],
+- [
+- AC_MSG_RESULT(enabled)
++ [])
++if test $support_curses -eq 1; then
+ AC_CHECK_HEADER([curses.h],
+ [
+ # test which libraray to use
+@@ -146,7 +147,7 @@
+ fi
+
+ if test $support_curses -eq 1; then
+- AC_SUBST(LDFLAGS_DYNAMIC, "$LDFLAGS -l$curseslib $tinfolib")
++ AC_SUBST(LDFLAGS_DYNAMIC, "-l$curseslib $tinfolib")
+ AC_DEFINE(HAVE_CURSES_H, 1, [curses library can be used])
+ fi
+
+@@ -154,8 +155,7 @@
+ [
+ support_curses=0
+ ])
+- ])
+-
++fi
+
+ NO_STL_SSTREAM=0
+ NO_STL_STRSTREAM=0
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -46,7 +46,7 @@
+ backtrace.h \
+ backtrace.cpp
+
+-xstow_LDFLAGS= $(LDFLAGS) $(LDFLAGS_DYNAMIC)
++xstow_LDADD= $(LDFLAGS_DYNAMIC)
+
+ if ENABLE_MERGE
+
+@@ -63,7 +63,7 @@
+ backtrace.h \
+ backtrace.cpp
+
+-merge_info_LDFLAGS= $(LDFLAGS) $(LDFLAGS_DYNAMIC)
++merge_info_LDADD= $(LDFLAGS_DYNAMIC)
+
+ endif
+