summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-02-09 15:25:29 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-02-09 15:25:29 +0100
commite49658404784a043f47f3d9dcb27938b244d33cb (patch)
tree3e1a0352244c6ff8614e419968f50c2ccc638648 /app-admin/rsyslog
parentdev-db/mongodb: drop x86 support -- upstream no longer supports x86 (diff)
downloadgentoo-e49658404784a043f47f3d9dcb27938b244d33cb.tar.gz
gentoo-e49658404784a043f47f3d9dcb27938b244d33cb.tar.bz2
gentoo-e49658404784a043f47f3d9dcb27938b244d33cb.zip
app-admin/rsyslog: Fix building without net-misc/curl
Closes: https://bugs.gentoo.org/646262 Package-Manager: Portage-2.3.24, Repoman-2.3.6 RepoMan-Options: --force
Diffstat (limited to 'app-admin/rsyslog')
-rw-r--r--app-admin/rsyslog/files/8-stable/rsyslog-8.32.0-fix-building-without-curl-r2.patch (renamed from app-admin/rsyslog/files/8-stable/rsyslog-8.32.0-fix-building-without-curl-r1.patch)61
-rw-r--r--app-admin/rsyslog/rsyslog-8.32.0-r2.ebuild (renamed from app-admin/rsyslog/rsyslog-8.32.0-r1.ebuild)2
2 files changed, 48 insertions, 15 deletions
diff --git a/app-admin/rsyslog/files/8-stable/rsyslog-8.32.0-fix-building-without-curl-r1.patch b/app-admin/rsyslog/files/8-stable/rsyslog-8.32.0-fix-building-without-curl-r2.patch
index 2706b4b581a0..23a189d03093 100644
--- a/app-admin/rsyslog/files/8-stable/rsyslog-8.32.0-fix-building-without-curl-r1.patch
+++ b/app-admin/rsyslog/files/8-stable/rsyslog-8.32.0-fix-building-without-curl-r2.patch
@@ -1,19 +1,10 @@
-https://github.com/rsyslog/rsyslog/pull/2378
+https://github.com/rsyslog/rsyslog/commit/d9475f133e3c79875a7c4ccd92038b7123c1f155
+https://github.com/rsyslog/rsyslog/commit/468eeb79b8da91fb71dfef6bfb25476b2a37f446
+https://github.com/rsyslog/rsyslog/commit/50205ced0fc22e74f26f2a07b557b69c5d30e168
---- a/configure.ac
-+++ b/configure.ac
-@@ -454,6 +454,8 @@ if test "$enable_libcurl" = "yes"; then
- )
- fi
-
-+AM_CONDITIONAL(ENABLE_LIBCURL, test "x${enable_libcurl}" = "xyes")
-+
- # klog
- AC_ARG_ENABLE(klog,
- [AS_HELP_STRING([--enable-klog],[Integrated klog functionality @<:@default=yes@:>@])],
--- a/grammar/rainerscript.c
+++ b/grammar/rainerscript.c
-@@ -1935,6 +1935,7 @@ done:
+@@ -1935,6 +1935,7 @@ num2ipv4(struct svar *__restrict__ const sourceVal) {
return(estr);
}
@@ -21,7 +12,7 @@ https://github.com/rsyslog/rsyslog/pull/2378
/* curl callback for doFunc_http_request */
static size_t
curlResult(void *ptr, size_t size, size_t nmemb, void *userdata)
-@@ -2010,6 +2011,7 @@ finalize_it:
+@@ -2010,6 +2011,7 @@ doFunc_http_request(struct cnffunc *__restrict__ const func,
}
RETiRet;
}
@@ -46,6 +37,19 @@ https://github.com/rsyslog/rsyslog/pull/2378
break;
default:
if(Debug) {
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -454,6 +454,8 @@ if test "$enable_libcurl" = "yes"; then
+ )
+ fi
+
++AM_CONDITIONAL(ENABLE_LIBCURL, test "x${enable_libcurl}" = "xyes")
++
+ # klog
+ AC_ARG_ENABLE(klog,
+ [AS_HELP_STRING([--enable-klog],[Integrated klog functionality @<:@default=yes@:>@])],
+
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -226,7 +226,6 @@ TESTS += \
@@ -88,3 +92,32 @@ https://github.com/rsyslog/rsyslog/pull/2378
endif # HAVE_VALGRIND
if ENABLE_ROOT_TESTS
+
+--- a/grammar/Makefile.am
++++ b/grammar/Makefile.am
+@@ -12,8 +12,11 @@ libgrammar_la_SOURCES = \
+ parserif.h \
+ grammar.h
+ libgrammar_la_CPPFLAGS = $(RSRT_CFLAGS) $(LIBLOGGING_STDLOG_CFLAGS)
+-#libgrammar_la_LIBADD = $(CURL_LIBS) $(RSRT_LIBS) $(SOL_LIBS)
+-libgrammar_la_LIBADD = $(CURL_LIBS)
++libgrammar_la_LIBADD =
++if ENABLE_LIBCURL
++libgrammar_la_CPPFLAGS += $(CURL_CFLAGS)
++libgrammar_la_LIBADD += $(CURL_LIBS)
++endif
+
+ #testdriver_SOURCES = testdriver.c libgrammar.la
+ #testdriver_CPPFLAGS = $(RSRT_CFLAGS)
+
+--- a/plugins/omelasticsearch/Makefile.am
++++ b/plugins/omelasticsearch/Makefile.am
+@@ -1,7 +1,7 @@
+ pkglib_LTLIBRARIES = omelasticsearch.la
+
+ omelasticsearch_la_SOURCES = omelasticsearch.c
+-omelasticsearch_la_CPPFLAGS = $(RSRT_CFLAGS) $(PTHREADS_CFLAGS)
++omelasticsearch_la_CPPFLAGS = $(RSRT_CFLAGS) $(PTHREADS_CFLAGS) $(CURL_CFLAGS)
+ omelasticsearch_la_LDFLAGS = -module -avoid-version
+ omelasticsearch_la_LIBADD = $(CURL_LIBS) $(LIBM)
+
diff --git a/app-admin/rsyslog/rsyslog-8.32.0-r1.ebuild b/app-admin/rsyslog/rsyslog-8.32.0-r2.ebuild
index 38c0e9447e8e..71638d76e217 100644
--- a/app-admin/rsyslog/rsyslog-8.32.0-r1.ebuild
+++ b/app-admin/rsyslog/rsyslog-8.32.0-r2.ebuild
@@ -48,7 +48,7 @@ else
doc? ( http://www.rsyslog.com/files/download/${PN}/${MY_URL_PREFIX}${PN}-doc-${MY_PV}.tar.gz -> ${MY_FILENAME_DOCS} )
"
- PATCHES=( "${FILESDIR}"/8-stable/${PN}-8.32.0-fix-building-without-curl-r1.patch )
+ PATCHES=( "${FILESDIR}"/8-stable/${PN}-8.32.0-fix-building-without-curl-r2.patch )
fi
LICENSE="GPL-3 LGPL-3 Apache-2.0"