summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/pwcrypt
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/pwcrypt')
-rw-r--r--app-admin/pwcrypt/Manifest1
-rw-r--r--app-admin/pwcrypt/metadata.xml7
-rw-r--r--app-admin/pwcrypt/pwcrypt-1.2.2-r1.ebuild28
-rw-r--r--app-admin/pwcrypt/pwcrypt-1.2.2.ebuild25
4 files changed, 61 insertions, 0 deletions
diff --git a/app-admin/pwcrypt/Manifest b/app-admin/pwcrypt/Manifest
new file mode 100644
index 000000000000..c3090a28b03a
--- /dev/null
+++ b/app-admin/pwcrypt/Manifest
@@ -0,0 +1 @@
+DIST pwcrypt-1.2.2.tar.gz 36902 SHA256 276710b34f9e66ba6b19ba43c46abaf727a28ed94bbd209a9bd28a655029c2e1 SHA512 41644e82f8306003e9346900d7a961e87a5b8103ebc411cf09b5e0e40d8253b4c38a83db57c60f09d2dd2663ecc2e2edc10ea2b6d095c102ee10ae251b471ddf WHIRLPOOL db45fbd5ead3cad86735ebcbab3d7716fdb45987c1ef292bc5a538f05248ddf2ef523da5203ead01924bc55d524b74ea59b801db82d0a30e0c7b3b46a08f8965
diff --git a/app-admin/pwcrypt/metadata.xml b/app-admin/pwcrypt/metadata.xml
new file mode 100644
index 000000000000..d4a08224d284
--- /dev/null
+++ b/app-admin/pwcrypt/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>hattya@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-admin/pwcrypt/pwcrypt-1.2.2-r1.ebuild b/app-admin/pwcrypt/pwcrypt-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..f8c293aff030
--- /dev/null
+++ b/app-admin/pwcrypt/pwcrypt-1.2.2-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="An improved version of cli-crypt (encrypts data sent to it from the cli)"
+HOMEPAGE="http://xjack.org/pwcrypt/"
+SRC_URI="http://xjack.org/pwcrypt/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DOCS=( CREDITS README )
+
+src_prepare() {
+ sed -i "s/make\( \|$\)/\$(MAKE)\1/g" Makefile.in || die
+ sed -i \
+ -e "/^LDFLAGS/s/= /= @LDFLAGS@ /" \
+ -e "/-install/s/ -s//" \
+ src/Makefile.in || die
+
+ tc-export CC
+}
diff --git a/app-admin/pwcrypt/pwcrypt-1.2.2.ebuild b/app-admin/pwcrypt/pwcrypt-1.2.2.ebuild
new file mode 100644
index 000000000000..1cce7360361d
--- /dev/null
+++ b/app-admin/pwcrypt/pwcrypt-1.2.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="An improved version of cli-crypt (encrypts data sent to it from the cli)"
+HOMEPAGE="http://xjack.org/pwcrypt/"
+SRC_URI="http://xjack.org/pwcrypt/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+src_prepare() {
+ tc-export CC
+}
+
+src_install() {
+ dobin src/pwcrypt
+ dodoc CREDITS README
+}