summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-06-20 13:54:28 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-06-20 16:05:27 +0200
commitc0bddfdde69a218af2b9da404f757d263d40743a (patch)
tree1f52432d677c648e144a76603364c0b96b93464a /app-admin/keepassxc
parentapp-admin/keepassxc: drop old 2.7.7-r2 (diff)
downloadgentoo-c0bddfdde69a218af2b9da404f757d263d40743a.tar.gz
gentoo-c0bddfdde69a218af2b9da404f757d263d40743a.tar.bz2
gentoo-c0bddfdde69a218af2b9da404f757d263d40743a.zip
app-admin/keepassxc: bump to 2.7.9
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-admin/keepassxc')
-rw-r--r--app-admin/keepassxc/Manifest1
-rw-r--r--app-admin/keepassxc/files/keepassxc-2.7.9-tests.patch12
-rw-r--r--app-admin/keepassxc/keepassxc-2.7.9.ebuild113
3 files changed, 126 insertions, 0 deletions
diff --git a/app-admin/keepassxc/Manifest b/app-admin/keepassxc/Manifest
index c195d9b9bc76..ea5f82e43830 100644
--- a/app-admin/keepassxc/Manifest
+++ b/app-admin/keepassxc/Manifest
@@ -1 +1,2 @@
DIST keepassxc-2.7.8-src.tar.xz 9764860 BLAKE2B edc5af2b7bd6173f8df4fa20fca54e78c40610d29b02ac9f9920382b8ead3ea293e22e578c353ffc1a374a23f1117a2595570d1de7053a1d36bcb40ed8eceb04 SHA512 c4767ced36d45855b83569d0fcbcfd384ef51d204dd703b006508d55cd7ac94ac36b5476f122fbe1dc6ec301a785e026722e8f0f961d5e339e10997a3871741a
+DIST keepassxc-2.7.9-src.tar.xz 9789312 BLAKE2B d9be3e577ae918160662558bb8bd724b5ca5982cb1bba5cda47f0dff042ea9a5c7393dd76ad195a7ba6c9b9e8371c4416840e4ff89e07c610d7351859586acfa SHA512 255102d3b3723a80cdd5f14cde2130b37807db226b48e985bcc2ab537b482e3fb23afde331e15ed02727e98b526d894aa4567f2e82039a2ad9d33a6ad9ea08a4
diff --git a/app-admin/keepassxc/files/keepassxc-2.7.9-tests.patch b/app-admin/keepassxc/files/keepassxc-2.7.9-tests.patch
new file mode 100644
index 000000000000..153b3c721018
--- /dev/null
+++ b/app-admin/keepassxc/files/keepassxc-2.7.9-tests.patch
@@ -0,0 +1,12 @@
+--- a/tests/CMakeLists.txt
++++ b/tests/CMakeLists.txt
+@@ -246,9 +246,6 @@ if(WITH_XC_NETWORKING OR WITH_XC_BROWSER)
+ add_unit_test(NAME testurltools SOURCES TestUrlTools.cpp LIBS ${TEST_LIBRARIES})
+ endif()
+
+-add_unit_test(NAME testcli SOURCES TestCli.cpp
+- LIBS testsupport cli ${ZXCVBN_LIBRARIES} ${TEST_LIBRARIES})
+-target_compile_definitions(testcli PRIVATE KEEPASSX_CLI_PATH="$<TARGET_FILE:keepassxc-cli>")
+
+ if(WITH_GUI_TESTS)
+ add_subdirectory(gui)
diff --git a/app-admin/keepassxc/keepassxc-2.7.9.ebuild b/app-admin/keepassxc/keepassxc-2.7.9.ebuild
new file mode 100644
index 000000000000..fe31c46f4f47
--- /dev/null
+++ b/app-admin/keepassxc/keepassxc-2.7.9.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic xdg
+
+DESCRIPTION="KeePassXC - KeePass Cross-platform Community Edition"
+HOMEPAGE="https://keepassxc.org/
+ https://github.com/keepassxreboot/keepassxc/"
+
+if [[ "${PV}" = *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_BRANCH="develop"
+ EGIT_REPO_URI="https://github.com/keepassxreboot/${PN}"
+else
+ if [[ "${PV}" == *_beta* ]] ; then
+ SRC_URI="https://github.com/keepassxreboot/${PN}/archive/${PV/_/-}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${P/_/-}"
+ else
+ SRC_URI="https://github.com/keepassxreboot/${PN}/releases/download/${PV}/${P}-src.tar.xz"
+ fi
+
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1 GPL-2 GPL-3"
+SLOT="0"
+IUSE="X autotype browser doc keeshare +network test yubikey"
+
+RESTRICT="!test? ( test )"
+REQUIRED_USE="autotype? ( X )"
+
+RDEPEND="
+ app-crypt/argon2:=
+ dev-libs/botan:3=
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ media-gfx/qrencode:=
+ sys-libs/readline:0=
+ sys-libs/zlib:=[minizip]
+ X? (
+ dev-qt/qtx11extras:5
+ )
+ autotype? (
+ x11-libs/libX11
+ x11-libs/libXtst
+ )
+ yubikey? (
+ dev-libs/libusb:1
+ sys-apps/pcsc-lite
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-qt/qttest:5
+"
+BDEPEND="
+ dev-qt/linguist-tools:5
+ doc? (
+ dev-ruby/asciidoctor
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.7.9-tests.patch"
+)
+
+src_prepare() {
+ if [[ "${PV}" != *_beta* ]] && [[ "${PV}" != *9999 ]] && [[ ! -f .version ]] ; then
+ printf '%s' "${PV}" > .version || die
+ fi
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # https://github.com/keepassxreboot/keepassxc/issues/5801
+ filter-lto
+
+ local -a mycmakeargs=(
+ # Gentoo users enable ccache via e.g. FEATURES=ccache or
+ # other means. We don't want the build system to enable it for us.
+ -DWITH_CCACHE=OFF
+ -DWITH_GUI_TESTS=OFF
+ -DWITH_TESTS="$(usex test)"
+ -DWITH_XC_AUTOTYPE="$(usex autotype)"
+ -DWITH_XC_DOCS="$(usex doc)"
+ -DWITH_XC_BROWSER="$(usex browser)"
+ -DWITH_XC_BROWSER_PASSKEYS="$(usex browser)"
+ -DWITH_XC_BOTAN3=ON
+ -DWITH_XC_FDOSECRETS=ON
+ -DWITH_XC_KEESHARE="$(usex keeshare)"
+ -DWITH_XC_NETWORKING="$(usex network)"
+ -DWITH_XC_SSHAGENT=ON
+ -DWITH_XC_UPDATECHECK=OFF
+ -DWITH_XC_YUBIKEY="$(usex yubikey)"
+ -DWITH_XC_X11="$(usex X)"
+ )
+ if [[ "${PV}" == *_beta* ]] ; then
+ mycmakeargs+=(
+ -DOVERRIDE_VERSION="${PV/_/-}"
+ )
+ fi
+ cmake_src_configure
+}