summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Pavljuchenkov (SpiderX) <spiderx@spiderx.dp.ua>2019-03-30 17:38:31 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-02-01 15:22:48 +0200
commit0cb85bc9eb54608aa28045ee1a45e02dc7041028 (patch)
tree2ada1e34c003ebfc6c30bc0dd84ad3af6f443be7 /app-admin/doctl/doctl-9999.ebuild
parentdev-libs/granite: bump to 5.5.0 (diff)
downloadgentoo-0cb85bc9eb54608aa28045ee1a45e02dc7041028.tar.gz
gentoo-0cb85bc9eb54608aa28045ee1a45e02dc7041028.tar.bz2
gentoo-0cb85bc9eb54608aa28045ee1a45e02dc7041028.zip
app-admin/doctl: new ebuild
A command line tool for DigitalOcean services Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Vladimir Pavljuchenkov <spiderx@spiderx.dp.ua> Closes: https://github.com/gentoo/gentoo/pull/11546 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-admin/doctl/doctl-9999.ebuild')
-rw-r--r--app-admin/doctl/doctl-9999.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-admin/doctl/doctl-9999.ebuild b/app-admin/doctl/doctl-9999.ebuild
new file mode 100644
index 000000000000..59e3c4d9aa3c
--- /dev/null
+++ b/app-admin/doctl/doctl-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_REPO_URI="https://github.com/digitalocean/${PN}.git"
+
+inherit bash-completion-r1 git-r3 go-module
+
+DESCRIPTION="A command line tool for DigitalOcean services"
+HOMEPAGE="https://github.com/digitalocean/doctl"
+SRC_URI=""
+
+LICENSE="Apache-2.0 MIT BSD BSD-2 ISC MPL-2.0"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+src_unpack() {
+ git-r3_src_unpack
+}
+
+src_compile() {
+ GOFLAGS="-v -x -mod=vendor" \
+ go build ./cmd/... || die "build failed"
+
+ ./doctl completion bash > doctl.bash || die "completion for bash failed"
+ ./doctl completion zsh > doctl.zsh || die "completion for sh failed"
+ ./doctl completion fish > doctl.fish || die "completion for fish failed"
+}
+
+src_test() {
+ GOFLAGS="-v -x -mod=vendor" \
+ go test -work ./do/... ./pkg/... . || die "test failed"
+}
+
+src_install() {
+ einstalldocs
+ dobin doctl
+
+ newbashcomp doctl.bash doctl
+ insinto /usr/share/zsh/site-functions
+ newins doctl.zsh _doctl
+ insinto /usr/share/fish/completion
+ newins doctl.fish doctl
+}