summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-09-05 12:50:50 +0100
committerSam James <sam@gentoo.org>2024-09-05 13:09:47 +0100
commitf3bb6bb643e02c3957e2f99cfefa1e2d3fd3c4cc (patch)
tree0666b637caaf8b86b2e79dbef34e384550ab096d
parentlinux-mod-r1.eclass: BDEPEND on dev-util/pahole (diff)
downloadgentoo-f3bb6bb643e02c3957e2f99cfefa1e2d3fd3c4cc.tar.gz
gentoo-f3bb6bb643e02c3957e2f99cfefa1e2d3fd3c4cc.tar.bz2
gentoo-f3bb6bb643e02c3957e2f99cfefa1e2d3fd3c4cc.zip
sys-kernel/gentoo-kernel-bin: BDEPEND on dev-util/pahole
Without this, if CONFIG_DEBUG_INFO_BTF_MODULES is enabled, as it is by default since 49e0de80b0d0b9bd5767d438dae773194d838525, while g-k-bin will seem to install fine, it's installed incorrectly. It also leads to external modules later not being loadable with relocation errors from unhandled BTF: ``` [ 1648.352993] module: x86/modules: Invalid relocation target, existing value is nonzero for type 1, loc 00000000bc2721ed, val ffffffffc11e7850 ``` Thanks-to: Ionen Wolkens <ionen@gentoo.org> Reported-by: Sebastian Engel <sighunter@gmx.de> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-kernel/gentoo-kernel-bin/gentoo-kernel-bin-6.10.8-r1.ebuild (renamed from sys-kernel/gentoo-kernel-bin/gentoo-kernel-bin-6.10.8.ebuild)4
1 files changed, 3 insertions, 1 deletions
diff --git a/sys-kernel/gentoo-kernel-bin/gentoo-kernel-bin-6.10.8.ebuild b/sys-kernel/gentoo-kernel-bin/gentoo-kernel-bin-6.10.8-r1.ebuild
index 5e3ffa99e33d..d5c4f186a89c 100644
--- a/sys-kernel/gentoo-kernel-bin/gentoo-kernel-bin-6.10.8.ebuild
+++ b/sys-kernel/gentoo-kernel-bin/gentoo-kernel-bin-6.10.8-r1.ebuild
@@ -11,7 +11,8 @@ inherit kernel-install toolchain-funcs unpacker
MY_P=linux-${PV%.*}
GENPATCHES_P=genpatches-${PV%.*}-$(( ${PV##*.} + 3 ))
-BINPKG=${PF/-bin}-1
+# XXX: Change me back to PF afer 6.10.8-r1
+BINPKG=${P/-bin}-1
DESCRIPTION="Pre-built Linux kernel with Gentoo patches"
HOMEPAGE="https://www.kernel.org/"
@@ -49,6 +50,7 @@ PDEPEND="
BDEPEND="
app-alternatives/bc
app-alternatives/lex
+ dev-util/pahole
virtual/libelf
app-alternatives/yacc
"