summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Ziak <0xe2.0x9a.0x9b@gmail.com>2018-04-05 15:37:11 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-04-05 16:12:09 +0200
commitdf1dc8da869a2b13f94abe8ab2e401f22e4659f3 (patch)
treed39924a8e2165b9e3792794a945428fe30aa9aee
parentapp-editors/efte: fdo-mime xdg-utils migration (diff)
downloadgentoo-df1dc8da869a2b13f94abe8ab2e401f22e4659f3.tar.gz
gentoo-df1dc8da869a2b13f94abe8ab2e401f22e4659f3.tar.bz2
gentoo-df1dc8da869a2b13f94abe8ab2e401f22e4659f3.zip
app-emulation/fuse: bump to version 1.5.2
Closes: https://github.com/gentoo/gentoo/pull/7770
-rw-r--r--app-emulation/fuse/Manifest1
-rw-r--r--app-emulation/fuse/fuse-1.5.2.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/app-emulation/fuse/Manifest b/app-emulation/fuse/Manifest
index 8903efc7746c..283fb858ce89 100644
--- a/app-emulation/fuse/Manifest
+++ b/app-emulation/fuse/Manifest
@@ -1,2 +1,3 @@
DIST fuse-1.5.0.tar.gz 1619748 BLAKE2B 6ffbea1c7a6572f2cdd3d293a438f6e37da2eadf299396358bed2e65db3aa9720333b62b28b4f0064ec5434c99a6a0b790737230f8ec0c01f96e50f594305bd1 SHA512 c13fdef6b23377e7d2b53e7f5b2db01447d12eafc0b9114fd8b83cd5058964a655a720810ab7dc6a6e1a1d9a33ffc787b5e46bf54df1259f4ba0ff78c3189421
DIST fuse-1.5.1.tar.gz 1623081 BLAKE2B 4b6cf747d15bc2d33a0baba88254a08187e8a615564236835da19d32f9afb312d5a5c90ac07a88d904019626b153546ecd8cd09b88fa16731af94ea54cd0e346 SHA512 d5f5b8a0e61f298a955450de208b29f8ab4fc0133c5c58e596f36f3834c088c946e19d7437dd1a6e73a89d32dcaf6ca9ce0fed8ec310c37aa6a6568be482abe4
+DIST fuse-1.5.2.tar.gz 1626746 BLAKE2B 38236b9457e975fe227e2a19ed0fb80cac022fbb0bd8fcb1e51666103c4abe8960b1bd166fc1d12ab4e0f32954f7c3f59625d57d456313f75ca023bf51477e0b SHA512 45507834eb70d1e74c8f58017f4ae0bb54e2560456eeadfa8b6888a1c79e9c9443cccb7ae9733b96a895f94040be820c57a7d698115c2f483e64ebc4fd734268
diff --git a/app-emulation/fuse/fuse-1.5.2.ebuild b/app-emulation/fuse/fuse-1.5.2.ebuild
new file mode 100644
index 000000000000..9670e420ea35
--- /dev/null
+++ b/app-emulation/fuse/fuse-1.5.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Free Unix Spectrum Emulator by Philip Kendall"
+HOMEPAGE="http://fuse-emulator.sourceforge.net"
+SRC_URI="mirror://sourceforge/fuse-emulator/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa ao backend-fbcon backend-sdl backend-svga backend-X gpm joystick memlimit png xml"
+
+# Only one UI back-end can be enabled at a time
+REQUIRED_USE="?? ( backend-fbcon backend-sdl backend-svga backend-X )"
+
+RDEPEND=">=app-emulation/libspectrum-1.4.1
+ alsa? ( media-libs/alsa-lib )
+ ao? ( media-libs/libao )
+ backend-sdl? ( media-libs/libsdl )
+ backend-svga? ( media-libs/svgalib )
+ backend-X? ( x11-libs/libX11 x11-libs/libXext )
+ !backend-fbcon? ( !backend-sdl? ( !backend-svga? ( !backend-X? ( x11-libs/gtk+:3 ) ) ) )
+ dev-libs/glib:2
+ gpm? ( sys-libs/gpm )
+ joystick? ( media-libs/libjsw )
+ png? ( media-libs/libpng:0= sys-libs/zlib )
+ xml? ( dev-libs/libxml2:2 )"
+DEPEND="${RDEPEND}
+ backend-fbcon? ( virtual/linux-sources )
+ dev-lang/perl
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog README THANKS )
+
+src_configure() {
+ local myconf=(
+ --without-win32
+ $(use_with alsa)
+ $(use_with ao libao)
+ $(use_with gpm)
+ $(use_with joystick)
+ $(use_enable joystick ui-joystick)
+ $(use_enable memlimit smallmem)
+ $(use_with png)
+ $(use_with xml libxml2)
+ )
+
+ if use backend-sdl; then
+ myconf+=("--with-sdl")
+ elif use backend-X; then
+ myconf+=("--without-gtk")
+ elif use backend-svga; then
+ myconf+=("--with-svgalib")
+ elif use backend-fbcon; then
+ myconf+=("--with-fb")
+ else
+ myconf+=("--with-gtk")
+ fi
+
+ econf "${myconf[@]}"
+}