summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-01-07 06:08:56 +0100
committerMichał Górny <mgorny@gentoo.org>2025-01-07 06:27:33 +0100
commitdcc68d7eedd3d0438ba91ce0da45ad1700acd149 (patch)
treef968cc661e0990df23fe8d28ddab90c41efc6d3e
parentdev-python/ml-dtypes: Bump to 0.5.1 (diff)
downloadgentoo-dcc68d7eedd3d0438ba91ce0da45ad1700acd149.tar.gz
gentoo-dcc68d7eedd3d0438ba91ce0da45ad1700acd149.tar.bz2
gentoo-dcc68d7eedd3d0438ba91ce0da45ad1700acd149.zip
dev-python/xcffib: Bump to 1.6.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/xcffib/Manifest1
-rw-r--r--dev-python/xcffib/xcffib-1.6.2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/xcffib/Manifest b/dev-python/xcffib/Manifest
index 87c165427006..2eb2d91a948d 100644
--- a/dev-python/xcffib/Manifest
+++ b/dev-python/xcffib/Manifest
@@ -1,2 +1,3 @@
DIST xcffib-1.5.0.tar.gz 89544 BLAKE2B cb3820a53eb7694078e5dbb175951b6dbdc445c06f397898e52319fd8a7633f2d8115f0d096a14b2b3de0c7b07918343d077705814574ff41de2bf06a12812c0 SHA512 aaa426b57d0d8dc45cb6a2036c862af6308fb5781667b8dba3f5ff399fe5e15912860d0bb696ac09f1efd4ffbbdaf7f555ef76039bd660f36f5c6179535b654f
DIST xcffib-1.6.0.tar.gz 101378 BLAKE2B 75b4e64f125d0948fc438202b81d0808acd988d363216382f42611e7f821f4df2cecd9464edfc0e89cacd4237d82fc0d0276a357f5625dc03811b1f9c0951a0d SHA512 53fbde4a61f061a460d8a33c70ce4189c7ea5ff30777cee0017f42fcee9d7e2954d48906d764feabbb0506be96a40350579043e9cea04f9886ff1e8f35ed3f9c
+DIST xcffib-1.6.2.tar.gz 101368 BLAKE2B a4768fd7d5da875c04a45beccd8ad8bcdc2459dd9a5b3b19fe40813376262a025c04af80d75927c26c2fb26e1a5fefb29e0ff406aae206ac0edab546535e40cf SHA512 f3d3c751c2307025b2f3b3cb523a31fe4f0560af428e2705d06fc1ce7980d36a5568ad1e73c9acde065347210d754c0f30718cff28fb823f09c65025c0ecfc4a
diff --git a/dev-python/xcffib/xcffib-1.6.2.ebuild b/dev-python/xcffib/xcffib-1.6.2.ebuild
new file mode 100644
index 000000000000..c4ee6e535384
--- /dev/null
+++ b/dev-python/xcffib/xcffib-1.6.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A drop in replacement for xpyb, an XCB python binding"
+HOMEPAGE="
+ https://github.com/tych0/xcffib/
+ https://pypi.org/project/xcffib/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+DEPEND="
+ x11-libs/libxcb
+"
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/cffi-1.1:=[${PYTHON_USEDEP}]
+ ' 'python*')
+ ${DEPEND}
+"
+BDEPEND="
+ test? (
+ x11-base/xorg-server[xvfb]
+ x11-apps/xeyes
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ rm -rf xcffib || die
+ epytest
+}