summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2023-07-27 14:23:02 +0300
committerMichał Górny <mgorny@gentoo.org>2023-07-28 17:58:29 +0200
commitbfa6403c7b591f24ab8b6b8c43ce595da4319525 (patch)
tree45be3b2a0e7b1edb508d9cfa1ed311b9242e9a38
parentdev-python/django-prometheus: Enable py3.12 (diff)
downloadgentoo-bfa6403c7b591f24ab8b6b8c43ce595da4319525.tar.gz
gentoo-bfa6403c7b591f24ab8b6b8c43ce595da4319525.tar.bz2
gentoo-bfa6403c7b591f24ab8b6b8c43ce595da4319525.zip
dev-python/sqlglot: new package, add 17.8.4
Signed-off-by: Alfred Wingate <parona@protonmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-db/mycli/mycli-1.26.1-r1.ebuild (renamed from dev-db/mycli/mycli-1.26.1.ebuild)0
-rw-r--r--dev-python/sqlglot/Manifest1
-rw-r--r--dev-python/sqlglot/metadata.xml21
-rw-r--r--dev-python/sqlglot/sqlglot-17.8.4.ebuild36
4 files changed, 58 insertions, 0 deletions
diff --git a/dev-db/mycli/mycli-1.26.1.ebuild b/dev-db/mycli/mycli-1.26.1-r1.ebuild
index 437959885397..437959885397 100644
--- a/dev-db/mycli/mycli-1.26.1.ebuild
+++ b/dev-db/mycli/mycli-1.26.1-r1.ebuild
diff --git a/dev-python/sqlglot/Manifest b/dev-python/sqlglot/Manifest
new file mode 100644
index 000000000000..e3b05d47c347
--- /dev/null
+++ b/dev-python/sqlglot/Manifest
@@ -0,0 +1 @@
+DIST sqlglot-17.8.4.tar.gz 8373260 BLAKE2B e3b67c940eb608a25705fd280c0165ad7f37db1fcda2f6bc55029af2ad673a789901fbb2e6af72b54d15b75bc84827afadb00cc965efdc3323587278a68f6cf5 SHA512 c1717e7e857ddb9ff700c739b76cd3714e57ae0f7b620593b4fdce53cbf8e37d39882fac1308c3277a236f695292ae1c15541e474d28bdd43d889c2756b172df
diff --git a/dev-python/sqlglot/metadata.xml b/dev-python/sqlglot/metadata.xml
new file mode 100644
index 000000000000..6288bb65af2e
--- /dev/null
+++ b/dev-python/sqlglot/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>parona@protonmail.com</email>
+ <name>Alfred Wingate</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">tobymao/sqlglot</remote-id>
+ <remote-id type="pypi">sqlglot</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sqlglot/sqlglot-17.8.4.ebuild b/dev-python/sqlglot/sqlglot-17.8.4.ebuild
new file mode 100644
index 000000000000..d44b4e19523f
--- /dev/null
+++ b/dev-python/sqlglot/sqlglot-17.8.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi optfeature
+
+DESCRIPTION="An easily customizable SQL parser and transpiler"
+HOMEPAGE="
+ https://sqlglot.com
+ https://github.com/tobymao/sqlglot/
+ https://pypi.org/project/sqlglot/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+EPYTEST_IGNORE=(
+ # Tests require pyspark or duckdb which aren't in the tree.
+ # Pandas would be a requirement normally, but it gets ignored by proxy.
+ "tests/dataframe/integration/test_dataframe.py"
+ "tests/dataframe/integration/test_grouped_data.py"
+ "tests/dataframe/integration/test_session.py"
+ "tests/test_executor.py"
+ "tests/test_optimizer.py"
+)
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "simplifying timedelta expressions" dev-python/dateutil
+}