summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-11-07 08:18:06 +0100
committerHans de Graaff <graaff@gentoo.org>2024-11-07 08:22:16 +0100
commit9f4a97bbb8fa28849b12cbc85dba78379a85a4b8 (patch)
tree94e37574ca04fd76472044596c7af187ead0f692
parentdev-ruby/parser: add 3.3.6.0 (diff)
downloadgentoo-9f4a97bbb8fa28849b12cbc85dba78379a85a4b8.tar.gz
gentoo-9f4a97bbb8fa28849b12cbc85dba78379a85a4b8.tar.bz2
gentoo-9f4a97bbb8fa28849b12cbc85dba78379a85a4b8.zip
dev-ruby/psych: add 5.2.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/psych/Manifest1
-rw-r--r--dev-ruby/psych/psych-5.2.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-ruby/psych/Manifest b/dev-ruby/psych/Manifest
index 912cffc5dd6f..225f31f6a9e9 100644
--- a/dev-ruby/psych/Manifest
+++ b/dev-ruby/psych/Manifest
@@ -1,3 +1,4 @@
DIST psych-4.0.6.gem 93696 BLAKE2B f5bea8262b401c0c291514dbd5ddc4aff389aeadb0b6483901b70a9562d267460260ddc5991e1540e51fb371a79d3a4a831bfdb8cb0b5dd9bd53cac939287545 SHA512 31f0ff5cd48e80ae81977f9519aa7952685b2da4a88b202aeb7214a364932cb1ca256f0934bed158d44a7d4d6e8cbb34928d33e731d0a8ba1a9885733ed32cd1
DIST psych-5.1.0.gem 39936 BLAKE2B f4d1b2b3699e36cf5f5101ad038ac3fd2e44b434df3e91516b850511684daeeb1eda32901ffbff870f533b8bda859b09bbd63e5ebe8a5ca3ce271ce869ef3a16 SHA512 94dd2a7b98d9d452fb24ba14d42d91969aa0d93f5737728e41a5032d76bad45d0e0b365f53447664cece448559d2e47ab35d95b4989016d9f0daf03b76d8a5cc
DIST psych-5.1.2.tar.gz 84689 BLAKE2B 868b653f28aa158777db34f33a76059e3f9565293328874af72ead5c2495fcdfabc145acfa5da8aecb0f4549f1012ad54e126274a7b8623188542363616099f7 SHA512 ed5440088c50bab86757b642f444903c804628ec361d138f54d2416def9c9fdd9728ece61fd6b4b56f47b13ab604aa99afb5710f49fcee0cf4ca3492f8cd7013
+DIST psych-5.2.0.tar.gz 86286 BLAKE2B 5dff687f9328703801cdfeb8a83ef69ecba06359de07ce2d4d182228672a338df2023c32205dd169fb9f45302637ec20cc826f8cd9603d9cc32c48543ebdec48 SHA512 f6add0340761920996c63d6bfb3992e166fe1d2cbdfe251de01700fa92f2fa987e9ebcaaa098e2ca611c5763b94e1e0f9ddd2fa886b4bb6c0b44d5919d204207
diff --git a/dev-ruby/psych/psych-5.2.0.ebuild b/dev-ruby/psych/psych-5.2.0.ebuild
new file mode 100644
index 000000000000..697f4fadadf5
--- /dev/null
+++ b/dev-ruby/psych/psych-5.2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTENSIONS=(ext/psych/extconf.rb)
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="psych.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A YAML parser and emitter"
+HOMEPAGE="https://github.com/ruby/psych"
+SRC_URI="https://github.com/ruby/psych/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+
+RDEPEND=">=dev-libs/libyaml-0.2.5"
+BDEPEND=">=dev-libs/libyaml-0.2.5"
+
+ruby_add_rdepend "dev-ruby/stringio"
+
+ruby_add_bdepend "test? (
+ dev-ruby/test-unit
+ dev-ruby/test-unit-ruby-core
+)"
+
+all_ruby_prepare() {
+ sed -e 's/__dir__/"."/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC}
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test -e 'require "lib/helper"; Dir["test/**/test_*.rb"].each{|f| require f}' || die
+}