summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-07-20 15:32:32 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-07-20 15:32:32 -0400
commit81e465561bd76a45d2da3cf57293c58649f9198b (patch)
treea8b6270dda7588315a4fc09999a5f9176cb2bf33
parentapp-editors/emact: Remove old. (diff)
downloadgentoo-81e465561bd76a45d2da3cf57293c58649f9198b.tar.gz
gentoo-81e465561bd76a45d2da3cf57293c58649f9198b.tar.bz2
gentoo-81e465561bd76a45d2da3cf57293c58649f9198b.zip
dev-python/pillow: fix broken build process
In 4.3.0 and 5.2.0, we had a broken way of passing flags to Pillow's build script. Flags would be passed fine in the compile phase, but would not be passed at all at the install phase, whichwas the equivalent of not sending flags at all. I'm committing straight to stable to 4.3.0-r2 because the build process is broken. Closes: https://bugs.gentoo.org/661308 Package-Manager: Portage-2.3.43, Repoman-2.3.10
-rw-r--r--dev-python/pillow/pillow-4.3.0-r2.ebuild10
-rw-r--r--dev-python/pillow/pillow-5.2.0.ebuild8
2 files changed, 10 insertions, 8 deletions
diff --git a/dev-python/pillow/pillow-4.3.0-r2.ebuild b/dev-python/pillow/pillow-4.3.0-r2.ebuild
index e6169726869f..25dddfce611f 100644
--- a/dev-python/pillow/pillow-4.3.0-r2.ebuild
+++ b/dev-python/pillow/pillow-4.3.0-r2.ebuild
@@ -52,10 +52,11 @@ PATCHES=(
"${FILESDIR}"/pillow-4.3.0-freetype2.9-test-metrics.patch
)
-python_compile() {
- # raqm not in portage yet
- local args=(
- --disable-raqm
+python_configure_all() {
+ # It's important that these flags are also passed during the install phase
+ # as well. Make sure of that if you change the lines below. See bug 661308.
+ mydistutilsargs=(
+ build_ext
--disable-platform-guessing
$(use_enable truetype freetype)
$(use_enable jpeg)
@@ -67,7 +68,6 @@ python_compile() {
$(use_enable webp webpmux)
$(use_enable zlib)
)
- distutils-r1_python_compile build_ext "${args[@]}"
}
python_compile_all() {
diff --git a/dev-python/pillow/pillow-5.2.0.ebuild b/dev-python/pillow/pillow-5.2.0.ebuild
index ad0c8bde22b6..1476c3915c58 100644
--- a/dev-python/pillow/pillow-5.2.0.ebuild
+++ b/dev-python/pillow/pillow-5.2.0.ebuild
@@ -46,8 +46,11 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}"
-python_compile() {
- local args=(
+python_configure_all() {
+ # It's important that these flags are also passed during the install phase
+ # as well. Make sure of that if you change the lines below. See bug 661308.
+ mydistutilsargs=(
+ build_ext
--disable-platform-guessing
$(use_enable truetype freetype)
$(use_enable jpeg)
@@ -59,7 +62,6 @@ python_compile() {
$(use_enable webp webpmux)
$(use_enable zlib)
)
- distutils-r1_python_compile build_ext "${args[@]}"
}
python_compile_all() {