summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-01-03 15:04:26 -0800
committerMatt Turner <mattst88@gentoo.org>2020-01-03 15:04:36 -0800
commit75f35c099849abdbb420792e09e0bfd157978ca3 (patch)
tree62a2cda9c12accb26642bae1ccddbe31ccbe1c2e
parentdev-go/logrus: Remove (diff)
downloadgentoo-75f35c099849abdbb420792e09e0bfd157978ca3.tar.gz
gentoo-75f35c099849abdbb420792e09e0bfd157978ca3.tar.bz2
gentoo-75f35c099849abdbb420792e09e0bfd157978ca3.zip
www-plugins/browserpass: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--profiles/package.mask8
-rw-r--r--www-plugins/browserpass/browserpass-3.0.6.ebuild53
2 files changed, 0 insertions, 61 deletions
diff --git a/profiles/package.mask b/profiles/package.mask
index 7a14fe5ae94f..552b6a6a7527 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -690,14 +690,6 @@ app-text/pdfshuffler
# Removal in 30 days. Bug #695392.
dev-python/quixote
-# Matt Turner <mattst88@gentoo.org> (2019-12-01)
-# browserpass ebuild ported to go-modules, so these modules now have no reverse
-# dependencies.
-# Removal in 30 days. Bugs #683286, #683310, #687462, #700792
-=www-plugins/browserpass-3.0.6
-dev-go/zglob
-dev-go/logrus
-
# Bernard Cafarelli <voyageur@gentoo.org> (2019-11-29)
# Beta for new major version with initial Python 3 support
=app-backup/rdiff-backup-1.4.0_beta*
diff --git a/www-plugins/browserpass/browserpass-3.0.6.ebuild b/www-plugins/browserpass/browserpass-3.0.6.ebuild
deleted file mode 100644
index 9792a5fd8f33..000000000000
--- a/www-plugins/browserpass/browserpass-3.0.6.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_PN=browserpass-native
-EGO_PN=github.com/browserpass/${MY_PN}
-
-if [[ ${PV} == 9999 ]]; then
- inherit golang-vcs
-else
- KEYWORDS="~amd64"
-# MY_P="${MY_PN}-${PV}"
-# S="${WORKDIR}/${MY_P}"
- SRC_URI="https://github.com/browserpass/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- inherit golang-vcs-snapshot
-fi
-inherit golang-build
-
-DESCRIPTION="WebExtension host binary for pass, a UNIX password manager"
-HOMEPAGE="https://github.com/browserpass/browserpass-native"
-LICENSE="ISC"
-SLOT="0"
-RDEPEND="app-crypt/gnupg"
-DEPEND="${RDEPEND}
- dev-go/logrus:=
- dev-go/zglob:="
-
-src_compile() {
- golang-build_src_compile
-
- pushd "src/${EGO_PN}" >/dev/null || die
- sed -e 's|%%replace%%|'${EPREFIX}'/usr/libexec/browserpass-native|' \
- -i browser-files/firefox-host.json browser-files/chromium-host.json || die
- popd >/dev/null || die
-}
-
-src_install() {
- exeinto /usr/libexec
- doexe browserpass-native
-
- pushd "src/${EGO_PN}" >/dev/null || die
- insinto /usr/$(get_libdir)/mozilla/native-messaging-hosts
- newins browser-files/firefox-host.json com.github.browserpass.native.json
-
- insinto /etc/chromium/native-messaging-hosts
- newins browser-files/chromium-host.json com.github.browserpass.native.json
-
- insinto /etc/opt/chrome/native-messaging-hosts
- newins browser-files/chromium-host.json com.github.browserpass.native.json
-
- popd >/dev/null || die
-}