summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2024-08-24 19:36:23 +0300
committerViorel Munteanu <ceamac@gentoo.org>2024-08-24 20:06:22 +0300
commit549de1fb1268304a15ba9330cd3487cf3df05000 (patch)
tree1d5131ecdc7aa6409d31345544f67bec353df304
parentdev-libs/cyrus-sasl: Fix empty sasldb2 generation when cross-compiling (diff)
downloadgentoo-549de1fb1268304a15ba9330cd3487cf3df05000.tar.gz
gentoo-549de1fb1268304a15ba9330cd3487cf3df05000.tar.bz2
gentoo-549de1fb1268304a15ba9330cd3487cf3df05000.zip
gui-libs/wf-config: add 0.9.0
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
-rw-r--r--gui-libs/wf-config/Manifest1
-rw-r--r--gui-libs/wf-config/wf-config-0.9.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/gui-libs/wf-config/Manifest b/gui-libs/wf-config/Manifest
index 9dd8238bdd6b..46036984214c 100644
--- a/gui-libs/wf-config/Manifest
+++ b/gui-libs/wf-config/Manifest
@@ -1 +1,2 @@
DIST wf-config-0.8.0.tar.xz 41200 BLAKE2B d56cd04c18c2cd8c0bac86493ad662244bde0e9cce1caf81d0fff34d9f2df2470c1aa8c95fead9e91dd5793d570b01dc6ef99b1986b8658b06ef93156a1526f8 SHA512 79cca2429a39ee81f853043698c57fc08025634926773253cff73fc564dcf203335b4b861d82b60a769bbab7b07be6a7e181c9ea29ad98ce930de20f9723893f
+DIST wf-config-0.9.0.tar.xz 42612 BLAKE2B 5f3b529f829f6fc6bdfe974633467707bba501eddca1a9d32f62c1d4ea6398e74ae9bc6f970de821e81fe7fbc4a26b77611587c637ab1961898084571b073ead SHA512 ac2ca69b7d96b9b145a4789f004705a2d7b323e6724e429a1e5a4544cd56828165a01f48a9863ceb92004c51c8f05729468f4a32c37545716f8d537d39e3236b
diff --git a/gui-libs/wf-config/wf-config-0.9.0.ebuild b/gui-libs/wf-config/wf-config-0.9.0.ebuild
new file mode 100644
index 000000000000..b90440cd81b9
--- /dev/null
+++ b/gui-libs/wf-config/wf-config-0.9.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="library for managing wayfire configuration files"
+HOMEPAGE="https://github.com/WayfireWM/wf-config"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/wf-config.git"
+ SLOT="0/0.10"
+else
+ SRC_URI="https://github.com/WayfireWM/wf-config/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+ SLOT="0/$(ver_cut 1-2)"
+fi
+
+LICENSE="MIT"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/libevdev
+ dev-libs/libxml2
+ media-libs/glm
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-libs/wayland-protocols
+ virtual/pkgconfig
+ test? ( dev-cpp/doctest )
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature test tests)
+ -Dlocale_test=false # requires de_DE locale to be installed
+ )
+
+ meson_src_configure
+}