summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2023-01-24 18:03:05 +0100
committerJakov Smolić <jsmolic@gentoo.org>2023-01-24 21:13:23 +0100
commit440fe04b760a9feb96f3f748747cda2cbd6013a6 (patch)
tree202c811a20b9714ac1d2558ac61dc5cd0aed82af
parentdev-ros/genpy: treeclean (diff)
downloadgentoo-440fe04b760a9feb96f3f748747cda2cbd6013a6.tar.gz
gentoo-440fe04b760a9feb96f3f748747cda2cbd6013a6.tar.bz2
gentoo-440fe04b760a9feb96f3f748747cda2cbd6013a6.zip
dev-ros/geodesy: treeclean
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
-rw-r--r--dev-ros/geodesy/Manifest1
-rw-r--r--dev-ros/geodesy/files/py3.patch13
-rw-r--r--dev-ros/geodesy/geodesy-0.5.6-r1.ebuild35
-rw-r--r--dev-ros/geodesy/geodesy-9999.ebuild35
-rw-r--r--dev-ros/geodesy/metadata.xml11
5 files changed, 0 insertions, 95 deletions
diff --git a/dev-ros/geodesy/Manifest b/dev-ros/geodesy/Manifest
deleted file mode 100644
index b1e2b4acf3d4..000000000000
--- a/dev-ros/geodesy/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST geographic_info-0.5.6.tar.gz 28130 BLAKE2B 4d7013543db91c02c470c6b6dcb6e00070d5356f91ace20b3bb97aafa71eff2b525fc11994796f2de103b1df40efe8358d19a7e8fc0b1290c73cc28c791f22ce SHA512 d2f41320d2b094c2ea04593941e35d2b5581b84cc2f599099880dd671255dd59bc8787ad4a5640539cc25a13592df2ec7a887e3ea171398cfeafeccc669bd7f0
diff --git a/dev-ros/geodesy/files/py3.patch b/dev-ros/geodesy/files/py3.patch
deleted file mode 100644
index 66ef4e5dd3ca..000000000000
--- a/dev-ros/geodesy/files/py3.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: geodesy/tests/test_wu_point.py
-===================================================================
---- geodesy.orig/tests/test_wu_point.py
-+++ geodesy/tests/test_wu_point.py
-@@ -127,7 +127,7 @@ class TestWuPoint(unittest.TestCase):
- self.assertEqual(wupts.get(uu).uuid(), uu)
-
- # test index() function
-- for i in xrange(len(uuids)):
-+ for i in range(len(uuids)):
- self.assertEqual(wupts.index(uuids[i]), i)
- self.assertEqual(wupts.points[i].id.uuid, uuids[i])
-
diff --git a/dev-ros/geodesy/geodesy-0.5.6-r1.ebuild b/dev-ros/geodesy/geodesy-0.5.6-r1.ebuild
deleted file mode 100644
index 291dd8ef6a56..000000000000
--- a/dev-ros/geodesy/geodesy-0.5.6-r1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-ROS_REPO_URI="https://github.com/ros-geographic-info/geographic_info"
-KEYWORDS="~amd64"
-ROS_SUBDIR=${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="Python and C++ interfaces for manipulating geodetic coordinates"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-ros/angles:0
- dev-ros/geographic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-ros/tf
- dev-ros/unique_id
- dev-ros/uuid_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
- $(python_gen_cond_dep "dev-python/pyproj[\${PYTHON_USEDEP}]")
- dev-libs/boost:=
-"
-DEPEND="${RDEPEND}
- dev-ros/geographic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- test? (
- dev-ros/rosunit[${PYTHON_SINGLE_USEDEP}]
- dev-cpp/gtest
- $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
- )"
-PATCHES=( "${FILESDIR}/py3.patch" )
diff --git a/dev-ros/geodesy/geodesy-9999.ebuild b/dev-ros/geodesy/geodesy-9999.ebuild
deleted file mode 100644
index 291dd8ef6a56..000000000000
--- a/dev-ros/geodesy/geodesy-9999.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-ROS_REPO_URI="https://github.com/ros-geographic-info/geographic_info"
-KEYWORDS="~amd64"
-ROS_SUBDIR=${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="Python and C++ interfaces for manipulating geodetic coordinates"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-ros/angles:0
- dev-ros/geographic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-ros/tf
- dev-ros/unique_id
- dev-ros/uuid_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
- $(python_gen_cond_dep "dev-python/pyproj[\${PYTHON_USEDEP}]")
- dev-libs/boost:=
-"
-DEPEND="${RDEPEND}
- dev-ros/geographic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- test? (
- dev-ros/rosunit[${PYTHON_SINGLE_USEDEP}]
- dev-cpp/gtest
- $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
- )"
-PATCHES=( "${FILESDIR}/py3.patch" )
diff --git a/dev-ros/geodesy/metadata.xml b/dev-ros/geodesy/metadata.xml
deleted file mode 100644
index 790827b81dc3..000000000000
--- a/dev-ros/geodesy/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>ros@gentoo.org</email>
- <name>Gentoo ROS Project</name>
- </maintainer>
- <upstream>
- <remote-id type="github">ros-geographic-info/geographic_info</remote-id>
- </upstream>
-</pkgmetadata>