summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-25 20:54:08 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-25 21:14:30 +0200
commit324c6d6e3b285bad3e737df1e6991cad5589e6db (patch)
treef972a2dee1ad61ef10277098bd20b6087eaad4dd
parentsys-cluster/cinder: 15.3.0 bump (diff)
downloadgentoo-324c6d6e3b285bad3e737df1e6991cad5589e6db.tar.gz
gentoo-324c6d6e3b285bad3e737df1e6991cad5589e6db.tar.bz2
gentoo-324c6d6e3b285bad3e737df1e6991cad5589e6db.zip
dev-python/pycryptodome: Bump to 3.9.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pycryptodome/Manifest1
-rw-r--r--dev-python/pycryptodome/pycryptodome-3.9.8.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pycryptodome/Manifest b/dev-python/pycryptodome/Manifest
index 23f5c70077db..15a6fd65a10c 100644
--- a/dev-python/pycryptodome/Manifest
+++ b/dev-python/pycryptodome/Manifest
@@ -1,2 +1,3 @@
DIST pycryptodome-3.9.4.tar.gz 11575825 BLAKE2B c153fe71179d633a5722480c4c42cc133100f524a8ba9d3cd9380b7e172564c276b70b97ef36437fa3a149c418903802f410c9d1807d5d72345dffb0aa568223 SHA512 d99e4e431d77856ce3ae33526984cadf2fa6aa82b1f692a2ad0ae893f6a1e9538e6d71d281578e6bd733a816664d1683364c64441196cbc6ee1278f9d6eac62c
DIST pycryptodome-3.9.7.tar.gz 15451558 BLAKE2B dca2cf3500d4011b8c37937c3f844db3e8e4afbec2c421552bcdc08df32ae46d8a2dadfaa2d48aac2356374f30154d439cb9e988e1035c570b0adebc58b259e1 SHA512 2ee8ec1094ca2b3813c25b96c71988db479b23ea2e76937275d0fd6421653efd1ce7a1e279c7a20a9de7edcb59e0927121a42112b85afc052edcd6ab2db74c26
+DIST pycryptodome-3.9.8.tar.gz 15633268 BLAKE2B 8c4f8d4839be0fb09556677514ee6c7f832684f20eb4e355cee87eb5b52a5c09e12712c1865ff89fb5dd6c628ca027374c7cab8a2287aafa4eecedf1095f1a12 SHA512 894e763720df284804fd686d5805980853b86773bb3097bf03d929818b9944e5a257e47414275f302966864751e50ae34dea19ad749910f1ceac31833a53ef7c
diff --git a/dev-python/pycryptodome/pycryptodome-3.9.8.ebuild b/dev-python/pycryptodome/pycryptodome-3.9.8.ebuild
new file mode 100644
index 000000000000..43e92f7ffb38
--- /dev/null
+++ b/dev-python/pycryptodome/pycryptodome-3.9.8.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="A self-contained cryptographic library for Python"
+HOMEPAGE="https://www.pycryptodome.org https://github.com/Legrandin/pycryptodome https://pypi.org/project/pycryptodome/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2 Unlicense"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="dev-libs/gmp:0
+ virtual/python-cffi[${PYTHON_USEDEP}]
+ !dev-python/pycrypto"
+BDEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/pycryptodome-3.9.4-parallel-make.patch"
+)
+
+distutils_enable_tests setup.py
+
+python_prepare_all() {
+ # parallel make fixes
+ # Multiple targets were compiling the same file, setuptools doesn't
+ # understand this and you get race conditions where a file gets
+ # overwritten while it's linking. This makes the files look like separate
+ # files so this race won't happen
+ ln src/blowfish.c src/blowfish_eks.c || die
+ ln src/mont.c src/mont_math.c || die
+
+ distutils-r1_python_prepare_all
+}