summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-09-03 11:12:54 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-09-03 14:21:44 +0200
commit29404b35e30ced8d9baedaf14db6526a4493230b (patch)
tree19ffd0c4ab2ff8de57688d1e863070d86df64907
parentdev-cpp/eigen: Fix SRC_URI after bitbucket hg shutdown (diff)
downloadgentoo-29404b35e30ced8d9baedaf14db6526a4493230b.tar.gz
gentoo-29404b35e30ced8d9baedaf14db6526a4493230b.tar.bz2
gentoo-29404b35e30ced8d9baedaf14db6526a4493230b.zip
media-gfx/synnefo: Try to fix build with systemwide-clang
Closes: https://bugs.gentoo.org/739982 Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--media-gfx/synnefo/files/synnefo-1.1.0-cxx11.patch99
-rw-r--r--media-gfx/synnefo/synnefo-1.1.0.ebuild4
2 files changed, 102 insertions, 1 deletions
diff --git a/media-gfx/synnefo/files/synnefo-1.1.0-cxx11.patch b/media-gfx/synnefo/files/synnefo-1.1.0-cxx11.patch
new file mode 100644
index 000000000000..fdc438f09d26
--- /dev/null
+++ b/media-gfx/synnefo/files/synnefo-1.1.0-cxx11.patch
@@ -0,0 +1,99 @@
+From 30691bdb98566482e1c29ee440cfc8531fac2616 Mon Sep 17 00:00:00 2001
+From: Kai-Uwe Behrmann <ku.b@gmx.de>
+Date: Thu, 22 Dec 2016 13:02:05 +0100
+Subject: [PATCH] fix some compiler warnings about string macro usage
+
+---
+ src/modules/devices/sy_devices.cpp | 12 ++++++------
+ src/modules/information/sy_info.cpp | 4 ++--
+ src/modules/settings/sy_settings.cpp | 2 +-
+ 3 files changed, 9 insertions(+), 9 deletions(-)
+
+diff --git a/src/modules/devices/sy_devices.cpp b/src/modules/devices/sy_devices.cpp
+index b477fd7..f60c4a2 100644
+--- a/src/modules/devices/sy_devices.cpp
++++ b/src/modules/devices/sy_devices.cpp
+@@ -146,10 +146,10 @@ int syDeviceGetProfile( oyConfig_s * device, uint32_t icc_profile_flags, oyProfi
+ {
+ oyOptions_s * options = 0;
+ oyOptions_SetFromText( &options,
+- "//"OY_TYPE_STD"/config/command",
++ "//" OY_TYPE_STD "/config/command",
+ "list", OY_CREATE_NEW );
+ oyOptions_SetFromText( &options,
+- "//"OY_TYPE_STD"/config/icc_profile.x_color_region_target",
++ "//" OY_TYPE_STD "/config/icc_profile.x_color_region_target",
+ "yes", OY_CREATE_NEW );
+ oyOptions_SetFromInt( &options, "///icc_profile_flags", icc_profile_flags, 0, OY_CREATE_NEW );
+ int error = oyDeviceAskProfile2( device, options, profile );
+@@ -595,7 +595,7 @@ int SyDevicesModule::installTaxiProfile(oyConfig_s * device)
+ "//" OY_TYPE_STD "/icc_profile_flags",
+ icc_profile_flags, 0, OY_CREATE_NEW );
+ oyOptions_SetFromText( &options,
+-+ "//"OY_TYPE_STD"/config/skip_ask_for_profile",
+++ "//" OY_TYPE_STD "/config/skip_ask_for_profile",
+ "yes", OY_CREATE_NEW );
+ error = oyDeviceSetup(device, options);
+ oyOptions_Release( &options );
+@@ -803,7 +803,7 @@ void SyDevicesModule::populateDeviceListing()
+ char ** texts = 0;
+
+ // get all configuration filters
+- oyConfigDomainList( "//"OY_TYPE_STD"/device/config.icc_profile",
++ oyConfigDomainList( "//" OY_TYPE_STD "/device/config.icc_profile",
+ &texts, &count, &rank_list ,0 );
+
+ for (i = 0; i < count; i++)
+@@ -960,7 +960,7 @@ oyConfig_s * SyDevicesModule::getCurrentDevice( void )
+ oyOptions_SetFromText( &options, "//" OY_TYPE_STD "/config/command",
+ "properties", OY_CREATE_NEW );
+ oyOptions_SetFromText( &options,
+- "//"OY_TYPE_STD"/config/icc_profile.x_color_region_target",
++ "//" OY_TYPE_STD "/config/icc_profile.x_color_region_target",
+ "yes", OY_CREATE_NEW );
+ if(current_device_class && current_device_name)
+ error = oyDeviceGet( OY_TYPE_STD, current_device_class, current_device_name,
+@@ -1003,7 +1003,7 @@ void SyDevicesModule::assignProfile( QString profile_name, oySCOPE_e scope )
+ "//" OY_TYPE_STD "/icc_profile_flags",
+ icc_profile_flags, 0, OY_CREATE_NEW );
+ oyOptions_SetFromText( &options,
+-+ "//"OY_TYPE_STD"/config/skip_ask_for_profile",
+++ "//" OY_TYPE_STD "/config/skip_ask_for_profile",
+ "yes", OY_CREATE_NEW );
+ oyDeviceSetup( device, options ); /* reinitialise */
+ oyOptions_Release( &options );
+diff --git a/src/modules/information/sy_info.cpp b/src/modules/information/sy_info.cpp
+index 9d194cf..3b4909c 100644
+--- a/src/modules/information/sy_info.cpp
++++ b/src/modules/information/sy_info.cpp
+@@ -231,7 +231,7 @@ void SyInfoModule::populateDeviceProfiles( QTreeWidgetItem * deviceListTree )
+ oyConfDomain_s * d = 0;
+
+ // get all configuration filters
+- oyConfigDomainList( "//"OY_TYPE_STD"/device/config.icc_profile",
++ oyConfigDomainList( "//" OY_TYPE_STD "/device/config.icc_profile",
+ &texts, &count, &rank_list ,0 );
+
+ for(i = count - 1; i >= 0; --i)
+@@ -266,7 +266,7 @@ void SyInfoModule::populateDeviceProfiles( QTreeWidgetItem * deviceListTree )
+ oyConfig_s * device = oyConfigs_Get( devices, j );
+ char * device_info = 0;
+ oyOptions_s * options = 0;
+- oyOptions_SetFromText( &options, "//"OY_TYPE_STD"/config/icc_profile.x_color_region_target",
++ oyOptions_SetFromText( &options, "//" OY_TYPE_STD "/config/icc_profile.x_color_region_target",
+ "yes", OY_CREATE_NEW );
+ oyOptions_SetFromInt( &options, "///icc_profile_flags", icc_profile_flags, 0, OY_CREATE_NEW );
+
+diff --git a/src/modules/settings/sy_settings.cpp b/src/modules/settings/sy_settings.cpp
+index a1c54ee..3f74c1d 100644
+--- a/src/modules/settings/sy_settings.cpp
++++ b/src/modules/settings/sy_settings.cpp
+@@ -213,7 +213,7 @@ void SySendNativeUpdate(const char * func)
+ {
+ // e.g. send native (e.g. X11) reload event
+ oyOptions_s * opts = oyOptions_New(NULL), * results = 0;
+- int error = oyOptions_Handle( "//"OY_TYPE_STD"/send_native_update_event",
++ int error = oyOptions_Handle( "//" OY_TYPE_STD "/send_native_update_event",
+ opts,"send_native_update_event",
+ &results );
+ oyOptions_Release( &opts );
diff --git a/media-gfx/synnefo/synnefo-1.1.0.ebuild b/media-gfx/synnefo/synnefo-1.1.0.ebuild
index eb126309b0bc..3ac8c9b7578d 100644
--- a/media-gfx/synnefo/synnefo-1.1.0.ebuild
+++ b/media-gfx/synnefo/synnefo-1.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -31,3 +31,5 @@ RDEPEND="${DEPEND}
"
DOCS=( AUTHORS.md README.md )
+
+PATCHES=( "${FILESDIR}/${P}-cxx11.patch" ) # bug 739982