summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-btrfs/python-btrfs-11.ebuild')
-rw-r--r--dev-python/python-btrfs/python-btrfs-11.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/python-btrfs/python-btrfs-11.ebuild b/dev-python/python-btrfs/python-btrfs-11.ebuild
new file mode 100644
index 0000000..d16f0d4
--- /dev/null
+++ b/dev-python/python-btrfs/python-btrfs-11.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python 3 module to inspect btrfs filesystems"
+HOMEPAGE="https://github.com/knorrie/python-btrfs"
+SRC_URI="https://github.com/knorrie/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND=""
+DEPEND=""
+
+python_install_all() {
+ use examples && local DOCS=( README.md CHANGES examples )
+ distutils-r1_python_install_all
+}