summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-binpkg/pypy3/pypy3-7.1.1.ebuild22
1 files changed, 21 insertions, 1 deletions
diff --git a/dev-binpkg/pypy3/pypy3-7.1.1.ebuild b/dev-binpkg/pypy3/pypy3-7.1.1.ebuild
index f1e198c..c104421 100644
--- a/dev-binpkg/pypy3/pypy3-7.1.1.ebuild
+++ b/dev-binpkg/pypy3/pypy3-7.1.1.ebuild
@@ -98,12 +98,32 @@ src_prepare() {
src_configure() {
tc-export CC
+ local jit_backend
+ if use jit; then
+ jit_backend='--jit-backend='
+
+ # We only need the explicit sse2 switch for x86.
+ # On other arches we can rely on autodetection which uses
+ # compiler macros. Plus, --jit-backend= doesn't accept all
+ # the modern values...
+
+ if use x86; then
+ if use cpu_flags_x86_sse2; then
+ jit_backend+=x86
+ else
+ jit_backend+=x86-without-sse2
+ fi
+ else
+ jit_backend+=auto
+ fi
+ fi
+
local args=(
--shared
$(usex jit -Ojit -O2)
$(usex sandbox --sandbox '')
- --jit-backend=auto
+ ${jit_backend}
pypy/goal/targetpypystandalone
)