summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'util-vserver/patches/0.30.210-r18/220_all_delete.patch')
-rw-r--r--util-vserver/patches/0.30.210-r18/220_all_delete.patch86
1 files changed, 0 insertions, 86 deletions
diff --git a/util-vserver/patches/0.30.210-r18/220_all_delete.patch b/util-vserver/patches/0.30.210-r18/220_all_delete.patch
deleted file mode 100644
index 30acc86..0000000
--- a/util-vserver/patches/0.30.210-r18/220_all_delete.patch
+++ /dev/null
@@ -1,86 +0,0 @@
-Index: util-vserver-0.30.210/contrib/manifest.dat.pathsubst
-===================================================================
---- util-vserver-0.30.210.orig/contrib/manifest.dat.pathsubst
-+++ util-vserver-0.30.210/contrib/manifest.dat.pathsubst
-@@ -19,6 +19,7 @@ base @PKGLIBDIR@/vserver.start
- @ENSC_HAVE_C99_COMPILER_TRUE@base @PKGLIBDIR@/vserver.start.bin
- base @PKGLIBDIR@/vserver.stop
- base @PKGLIBDIR@/vserver.suexec
-+base @PKGLIBDIR@/vserver.delete
- core @PKGLIBDIR@/util-vserver-vars
- build @PKGLIBDIR@/rpm-fake.so
- legacy @LEGACYDIR@/save_s_context
-Index: util-vserver-0.30.210/scripts/Makefile-files
-===================================================================
---- util-vserver-0.30.210.orig/scripts/Makefile-files
-+++ util-vserver-0.30.210/scripts/Makefile-files
-@@ -53,7 +53,8 @@ scripts_pkglib_src_DTA = scripts/functio
- scripts/vserver.functions \
- scripts/vserver.start \
- scripts/vserver.stop \
-- scripts/vserver.suexec
-+ scripts/vserver.suexec \
-+ scripts/vserver.delete
-
- scripts_pkglib_gen_DTA = scripts/util-vserver-vars
-
-Index: util-vserver-0.30.210/scripts/vserver
-===================================================================
---- util-vserver-0.30.210.orig/scripts/vserver
-+++ util-vserver-0.30.210/scripts/vserver
-@@ -57,6 +57,7 @@ Possible commands are:
-
- build <buildopts>*
- ... builds a new vserver from scratch
-+ delete ... remove a vserver
-
- unify [-R]
- ... (de)unify vserver
-@@ -199,7 +200,7 @@ test "$2" != start -o -n "$OPTION_NONAME
-
- . $__PKGLIBDIR/vserver.functions
- case "$2" in
-- (start|stop)
-+ (start|stop|delete)
- shift 2
- . $__PKGLIBDIR/vserver.$cmd
- ;;
-Index: util-vserver-0.30.210/scripts/vserver.delete
-===================================================================
---- /dev/null
-+++ util-vserver-0.30.210/scripts/vserver.delete
-@@ -0,0 +1,34 @@
-+#! /bin/bash
-+# $Id$
-+
-+# Copyright (C) 2006 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
-+#
-+# This program is free software; you can redistribute it and/or modify
-+# it under the terms of the GNU General Public License as published by
-+# the Free Software Foundation; version 2 of the License.
-+#
-+# This program is distributed in the hope that it will be useful,
-+# but WITHOUT ANY WARRANTY; without even the implied warranty of
-+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-+# GNU General Public License for more details.
-+#
-+# You should have received a copy of the GNU General Public License
-+# along with this program; if not, write to the Free Software
-+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
-+
-+. "$_LIB_VSERVER_BUILD_FUNCTIONS"
-+. "$_LIB_VSERVER_BUILD_FUNCTIONS_PKGMGMT"
-+
-+if test -z "$OPTION_SILENT" ; then
-+ read -p "Are you sure you want to delete the vserver $vserver (y/N) " deleteok
-+ if [[ ${deleteok} != [Yy] ]]; then
-+ exit 2
-+ fi
-+fi
-+
-+isVserverRunning "$VSERVER_DIR" &&
-+ "${SELF[@]}" $OPTION_SILENT --sync "$vserver" stop
-+
-+base.init
-+pkgmgmt.initVariables
-+rm -rf "`readlink -f "$VSERVER_DIR"/vdir`" "$VSERVER_DIR" "$PKGCFGDIR"